Bug 1797699 - fix the order of the menu items in the project access dropdown
Summary: fix the order of the menu items in the project access dropdown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 16:50 UTC by Debsmita Santra
Modified: 2020-05-13 21:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4124 None closed Bug 1797699: fix the order of the menu items in the project access dropdown 2020-04-21 22:15:27 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:47 UTC

Description Debsmita Santra 2020-02-03 16:50:26 UTC
Description of problem:
The menu items in role dropdown is following any order

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Click on Advanced -> Project Access

Actual results:
There is no logical basis behind the order in the Project Access Menu Dropdown.

Expected results:
The menu items should be in alphabetical order

Additional info:

Comment 2 Karthik Jeeyar 2020-02-05 12:50:01 UTC
Verification details

Build number : 4.4.0-0.ci-2020-02-04-101704
Cluster Url : https://console-openshift-console.apps.rhamilto.devcluster.openshift.com/topology/ns/kube-node-lease
Browsers : chrome (Version 79.0.3945.88), firefox (66.0.2)
Verified as : kubeadmin and basic user is not having permission to visit the page

Comment 4 errata-xmlrpc 2020-05-13 21:58:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.