Bug 1797701 - storage class cannot be changed back to the default one
Summary: storage class cannot be changed back to the default one
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 17:04 UTC by Filip Krepinsky
Modified: 2020-05-13 21:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: storage class could not be changed back to the default (empty) one in Disk modals Fix and Result: storage class can be changed back to the default (empty) one
Clone Of:
Environment:
Last Closed: 2020-05-13 21:58:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4217 None closed Bug 1797701: allow changing the storage class back to the default one 2020-04-22 14:14:54 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:58:49 UTC

Description Filip Krepinsky 2020-02-03 17:04:18 UTC
Description of problem:
storage class cannot be changed back to the default one - this happens in all places with storage (VM / VM template wizard and their details)



How reproducible:
100

Steps to Reproduce:
1. Create a template
2. Create a blank disk with a storage class
3. Edit disk and remove storage class (default one should be used instead)
4. Select ok - everything works without an error


Actual results:
Storage class is not changed and the old one is still present

Expected results:
Storage class would be changed to the default one

Comment 4 Guohua Ouyang 2020-02-20 07:21:11 UTC
verified on 4.4.0-0.nightly-2020-02-17-022408

Comment 6 errata-xmlrpc 2020-05-13 21:58:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.