Bug 1797790 - MachineConfigDaemonReasonAnnotationKey gives node description beyond 262144 characters
Summary: MachineConfigDaemonReasonAnnotationKey gives node description beyond 262144 c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.z
Assignee: Erica von Buelow
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On: 1809693
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 21:18 UTC by Erica von Buelow
Modified: 2020-03-26 07:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1792914
Environment:
Last Closed: 2020-03-26 07:21:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1432 None closed Bug 1797790: [release-4.2] prevent hitting annotation max size limit on nodes (cherry-pick) 2020-05-12 15:35:13 UTC
Red Hat Product Errata RHBA-2020:0826 None None None 2020-03-26 07:21:38 UTC

Comment 4 Michael Nguyen 2020-03-16 15:52:16 UTC
verified on 4.2.0-0.nightly-2020-03-16-055952


apiVersion: v1
kind: Node
metadata:
  annotations:
    machine.openshift.io/machine: openshift-machine-api/ci-ln-q7xk1g2-d5d6b-dtm64-worker-us-west-1a-6drrq
    machineconfiguration.openshift.io/currentConfig: rendered-worker-4605cb9bf152301e9b58405831c365f0
    machineconfiguration.openshift.io/reason: machineconfiguration.openshift.io/desiredConfig
      annotation not found on node 'ip-10-0-133-186.us-west-1.compute.internal'
    machineconfiguration.openshift.io/state: Degraded
    volumes.kubernetes.io/controller-managed-attach-detach: "true"
  creationTimestamp: "2020-03-16T15:09:40Z"
  labels:
    beta.kubernetes.io/arch: amd64
    beta.kubernetes.io/instance-type: m4.xlarge
    beta.kubernetes.io/os: linux

Comment 5 Antonio Murdaca 2020-03-16 16:06:24 UTC
(In reply to Michael Nguyen from comment #4)
> verified on 4.2.0-0.nightly-2020-03-16-055952
> 
> 
> apiVersion: v1
> kind: Node
> metadata:
>   annotations:
>     machine.openshift.io/machine:
> openshift-machine-api/ci-ln-q7xk1g2-d5d6b-dtm64-worker-us-west-1a-6drrq
>     machineconfiguration.openshift.io/currentConfig:
> rendered-worker-4605cb9bf152301e9b58405831c365f0
>     machineconfiguration.openshift.io/reason:
> machineconfiguration.openshift.io/desiredConfig
>       annotation not found on node
> 'ip-10-0-133-186.us-west-1.compute.internal'


wait, wait, wait, why there's no desiredConfig annotation here? where did it go?

>     machineconfiguration.openshift.io/state: Degraded
>     volumes.kubernetes.io/controller-managed-attach-detach: "true"
>   creationTimestamp: "2020-03-16T15:09:40Z"
>   labels:
>     beta.kubernetes.io/arch: amd64
>     beta.kubernetes.io/instance-type: m4.xlarge
>     beta.kubernetes.io/os: linux

Comment 6 Erica von Buelow 2020-03-16 18:49:31 UTC
(In reply to Antonio Murdaca from comment #5)
It was explicitly deleted to trigger the bug. I don't think it's possible to get into this situation without user error (right now), but the problem is that it prevents the controller from recovering and can block other important functions by blocking all annotation updates.

Comment 8 errata-xmlrpc 2020-03-26 07:21:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0826


Note You need to log in before you can comment on or make changes to this bug.