Bug 1797801 - Metering IPV6 install fails when TLS/authentication is enabled
Summary: Metering IPV6 install fails when TLS/authentication is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metering Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: tflannag
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-03 22:11 UTC by tflannag
Modified: 2020-05-04 11:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:33:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-metering pull 1092 0 None closed Bug 1797801: Update the Hive and reporting-operator charts to work with single-stack ipv4 and ipv6. 2020-04-27 14:35:39 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:33:36 UTC

Description tflannag 2020-02-03 22:11:38 UTC
Description of problem:
When attempting to run a Metering install on an AWS IPV6 cluster with TLS/authentication enabled (the default setting), the Hive metastore/server and reporting-operator ghostunnel sidecar containers fail to communicate with each other. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Peter Ruan 2020-03-13 06:59:13 UTC
verified with 4.4 tagged metering

pruan@MacBook-Pro ~/workspace/gocode/src/github.com/operator-framework/operator-metering (master●)$ oc get pods
NAME                                  READY   STATUS    RESTARTS   AGE
hive-metastore-0                      2/2     Running   0          3m17s
hive-server-0                         3/3     Running   0          3m17s
metering-operator-7b96748b96-96njb    2/2     Running   0          5m54s
presto-coordinator-0                  2/2     Running   0          2m43s
reporting-operator-6fc7fc5c4c-nl2pl   2/2     Running   0          2m8s

Comment 5 errata-xmlrpc 2020-05-04 11:33:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.