Bug 179782 - Gnome + KDE hangs after login at splash screen
Summary: Gnome + KDE hangs after login at splash screen
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL: none
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-02 21:33 UTC by dex
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 01:46:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corrupt .fonts.cache-2 file (133.01 KB, application/octet-stream)
2006-02-02 21:43 UTC, dex
no flags Details

Description dex 2006-02-02 21:33:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
unable to boot into gui after yesterdays update
Attached bad ~/.font.cache-2 file

Version-Release number of selected component (if applicable):
fontconfig-2.3.93.cvs20060131-1

How reproducible:
Always

Steps to Reproduce:
1.login as root or user
2.
3.
  

Actual Results:  Hangs at KDE or GNOME splash screen

Expected Results:  Boot gui

Additional info:

Work around delete ~/.font.cache-2 file for each user
according to bill nottingham:
http://www.redhat.com/archives/fedora-test-list/2006-February/msg00195.html

Comment 1 dex 2006-02-02 21:43:34 UTC
Created attachment 124072 [details]
corrupt .fonts.cache-2 file

Comment 2 Sammy 2006-02-02 23:28:34 UTC
Some of us also found that not having a .fonts directory with a fonts.dir
inside lead to a crash during the early login.

Comment 3 David Anderson 2006-04-20 00:18:57 UTC
I got this after updating to FC 5.

I found that a new user could log in find, but my existing one couldn't.

I played around with removing various dotfiles from my home directory until I 
found out which one was the problem - it was the .fonts.cache-2 files.

This is a serious bug - as I say, after upgrading to FC5, I couldn't log in any 
more.

Comment 4 David Anderson 2006-09-11 09:53:41 UTC
The severity of this bug should be upgraded to "high" or "urgent". Not being 
able to log in after upgrading is not a "Normal" priority bug.

Comment 5 dex 2007-01-12 18:45:20 UTC
close this bug ...

Comment 6 David Anderson 2007-01-12 19:39:37 UTC
Dex: Why? Has it been fixed? I worked round it by removing files - but will it 
occur again on future upgrades?

Comment 7 Behdad Esfahbod 2007-10-26 01:46:42 UTC
This was caused by early versions of fontconfig 2.3.x that were in some test
releases of fedora.  The actual bug has been long fixed.

Comment 8 David Anderson 2007-10-31 16:36:03 UTC
Comment on #7: I've never run a test release; this bug was in the gold master 
of FC5 which I was running. I'm glad to hear that it's apparently fixed now, 
though the comment that it was in a test makes me wonder if it's the same bug?


Note You need to log in before you can comment on or make changes to this bug.