Bug 1797840 - Warning about missing the cloud-provider-config configmap in registry operator log
Summary: Warning about missing the cloud-provider-config configmap in registry operato...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 02:19 UTC by Wenjing Zheng
Modified: 2020-07-13 17:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the operator always reported about missing cloud-provider-config even if the cluster is not supposed to have it Consequence: noise in the logs Fix: report only if debug is enabled Result: clean logs
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:09 UTC

Description Wenjing Zheng 2020-02-04 02:19:24 UTC
Description of problem:
There are so many warning in image registry operator log as below:
I0204 01:58:40.462449      13 caconfig.go:123] missing the cloud-provider-config configmap: configmap "cloud-provider-config" not found

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-03-163409

How reproducible:
always

Steps to Reproduce:
1.Launch a cluster
2.Check image registry operator log:
$ oc logs pods/cluster-image-registry-operator-856fddc779-25kz6 -c cluster-image-registry-operator
3.

Actual results:
So many warning about missing the cloud-provider-config configmap

Expected results:
Should be no such warning

Additional info:

Comment 2 Wenjing Zheng 2020-02-07 07:17:18 UTC
No such warning in registry operator in 4.4.0-0.nightly-2020-02-06-230833 now.

Comment 3 Wenjing Zheng 2020-02-10 06:43:48 UTC
I can still see this warning with storage=emptyDir on 4.4.0-0.nightly-2020-02-10-013941, so re-open this bug.

Comment 7 XiuJuan Wang 2020-04-23 03:35:56 UTC
https://github.com/openshift/cluster-image-registry-operator/pull/507 is for 4.5 version.
Cherry-pick for 4.4 is failed, https://github.com/openshift/cluster-image-registry-operator/pull/507#issuecomment-611648970

And could still see the message 'missing the cloud-provider-config configmap: configmap "cloud-provider-config" not found' in 4.4.0-0.nightly-2020-04-22-200542

Comment 8 Oleg Bulatov 2020-04-23 09:28:49 UTC
Oops, can you verify it on 4.5?

Comment 10 XiuJuan Wang 2020-04-24 02:39:32 UTC
Can‘t reproduce this issue now in 4.5.0-0.nightly-2020-04-21-103613

Comment 14 errata-xmlrpc 2020-07-13 17:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.