Bug 1797931 - [RFE] Installed Operators list page should support ordering on multiple columns
Summary: [RFE] Installed Operators list page should support ordering on multiple columns
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 09:15 UTC by Yadan Pei
Modified: 2020-07-13 17:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The Installed Operators list is only sortable by the Name column. Consequence: Users are unable to sort the list by other columns, thus limiting sort options. Fix: Additional columns are sortable. Result: Users can not sort the list by more than just the name column.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4312 None closed Bug 1797931: Make namespace, deployment cols sortable in Installed Operators table 2020-06-23 08:23:35 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:09 UTC

Description Yadan Pei 2020-02-04 09:15:46 UTC
Description of problem:
When cluster admin view Installed Operators for one project especially for all projects, all CSVs will be shown on the list page, some of them are in Copied status, it's hard to filter the Operators based on their Status, Namespace, Deployment. We should support order/filter with these columns

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-03-043955

How reproducible:
Always

Steps to Reproduce:
1. cluster admin view Installed Operators at Operators -> Installed Operators
2. Choose all projects or specific project 'openshift-operators'

Actual results:
2. User can only filter and order by Name

Expected results:
2. It's better if we can filter/order by Status, Namespace, or Deployment, especially when all projects are selected, it's hard to filter

Additional info:

Comment 1 Robb Hamilton 2020-02-25 19:33:43 UTC
Note we're choosing to punt on making `Status` sortable at this time.  See https://github.com/openshift/console/pull/4312#discussion_r384078614

Comment 5 Yadan Pei 2020-03-06 06:35:40 UTC
Now except Name col, Namespace & Deployment column also support ordering. I think the original issue has been solved, it's much easier to sort.

Verified on 4.5.0-0.ci-2020-03-04-223611

Comment 7 errata-xmlrpc 2020-07-13 17:13:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.