Bug 179794 - May need note that not all RAID contollers are supported
May need note that not all RAID contollers are supported
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc5-relnotes-traqr
  Show dependency treegraph
 
Reported: 2006-02-02 18:43 EST by Stuart Ellis
Modified: 2007-04-18 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: WIKI
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 01:12:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Ellis 2006-02-02 18:43:07 EST
Description of problem:

Users with ATA RAID controllers may find that the hardware RAID doesn't work if
the controller is not one of those currently supported by dmraid (dmraid -l
produces a list of supported devices).

I'm not sure what the recommended process is for unsupported ATA RAID devices -
vendor-provided Fedora driver disks seem rare.
Comment 1 Karsten Wade 2006-02-02 20:16:26 EST
Blogging master tracker for FC5 relnotes.

Who would be the beat writer to own this info and track down the facts?
Comment 2 Debbie Deutsch 2006-02-02 22:27:00 EST
I am not the beat writer.  However, I have been paying attention to this 
issue.  Under FC4 the usual advice was to not configure the RAID array in the 
BIOS and to use software RAID instead if the controller was not supported by 
dmraid.  Of course this needs to be confirmed for FC5.  Stuart has told me 
that the dmraid developer is Heinz Mauelshagen, and the contact point is the 
ata-raid list:

https://www.redhat.com/mailman/listinfo/ataraid-list

I'd volunteer to put this to bed, but I am away from home on a business trip 
and can't promise to have any time available until Saturday.
Comment 3 Karsten Wade 2006-02-03 09:08:19 EST
Feel free to check into the beat when you get available:

http://fedoraproject.org/wiki/Docs/Beats/Kernel

If you don't see the information there, or it needs some additional info, go
ahead and add it. There may still be time by this weekend to get the info in the
ISO for test3.  We also publish a latest version of the relnotes that is linked
from the top of the relnotes in the ISO.

Thanks.
Comment 4 Stuart Ellis 2006-02-11 05:59:34 EST
This thread on the development mailing list may also be useful:

https://www.redhat.com/archives/fedora-devel-list/2006-February/msg00339.html
Comment 5 Karsten Wade 2006-02-28 01:12:26 EST
Admonition included in the Installer beat:

 Anaconda now supports installation on several IDE software RAID chipsets using
dmraid. To disable this feature, add the nodmraid option at the boot: prompt.
For more information, refer to [WWW] http://fedoraproject.org/wiki/DmraidStatus .

    *

      /!\ Do not boot only half of a dmraid RAID1 (mirror)

      Various situations may occur that cause dmraid to break the mirror, and if
you boot in read/write mode into only one of the mirrored disks, it causes the
disks to fall out of sync. No symptoms arise, since the primary disk is reading
and writing to itself. But if you attempt to re-establish the mirror without
first synchronizing the disks, you could corrupt the data and have to reinstall
from scratch without a chance for recovery.

      If the mirror is broken, you should be able to resync from within the RAID
chipset BIOS or by using the dd command. Reinstallation is always an option. 

Note You need to log in before you can comment on or make changes to this bug.