Bug 179799 - modify i18n in FDP
modify i18n in FDP
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tommy Reynolds
:
Depends On:
Blocks: fc5-relnotes-traqr
  Show dependency treegraph
 
Reported: 2006-02-02 19:49 EST by Karsten Wade
Modified: 2009-07-07 00:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: cvs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 14:30:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2006-02-02 19:49:21 EST
We may move this up, at least in terms of getting it all working in your
sandbox.  We are looking to connect into the i18n.redhat.com tools for FC5,
meaning that we can get the relnotes translated across many possible languages
between test3 and FC5.

If we move fast enough, it's possible we could do this for test3.  For
$REASONS_UNSPEAKABLE, I think we may have, oh, say an extra five days to
accomplish this, starting now.

release-notes/en/RELEASE-NOTES-en.xml
...

Is this the idea?  Or ...

I'm blocking the FC5 relnotes tracker with this one, we want to do it.

Carry on!
Comment 1 Paul W. Frields 2006-02-17 23:43:23 EST
Are we considered ready to go for i18n.redhat.com yet?  What is remaining?
Comment 2 Karsten Wade 2006-02-18 08:53:32 EST
Translation Project leaders:

We think the release notes are ready to hook into i18n.redhat.com.

You want to post the .po files for translation no later than 27 Feb.  We will
have new content at that time, generated from the Wiki.

You may want to post the existing .po files.  Only a % of the content is going
to change between now and then, this would give translators an early start.

Do you need anything more from us?

Our schedule is here:

http://fedoraproject.org/wiki/DocsProject/Schedule
Comment 3 Karsten Wade 2006-02-27 23:57:26 EST
I think we have a snag that we'll have to solve on 28 Feb.  The translator
leadership hasn't been able to get any .pot files because of a missing xml2po
application, iirc.

Also, I don't know if i18n.redhat.com is available for this release, or are we
doing this with the translators who have cvs.fedora accounts?
Comment 4 Tommy Reynolds 2006-02-28 06:53:38 EST
For the record, xml2po(1) is part of the "gnome-doc-utils" package.  Is there a
problem obtaining this package?  It is part of the "Development/Tools" group in
Anaconda & system-config-packages.
Comment 5 Paul W. Frields 2006-02-28 08:19:45 EST
Also note that this package doesn't have any dependencies on the sizable GNOME
libraries -- only python, libxml2 and libxslt, all of which I would expect users
have installed, so "yum install gnome-doc-utils" won't drag in a ton of extra
baggage.
Comment 6 Tommy Reynolds 2006-02-28 12:27:48 EST
Perhaps the issue is that some of our I18N workers are on that other operating
system; you know, the one you need CYGWIN to retain your sanity ;-)

I've now taken the position that it is good, nay, required, practice to include
the .POT file as part of the CVS archive.  Although, it's a generated file, not
everyone who needs to work with it can do the generating.  Everybody can handle
the .POT and .PO files with native tools, so I'll make a policy exception here. 
Comment 7 Karsten Wade 2006-02-28 13:14:56 EST
Sounds cool to me.  We do have a policy of not providing tools that support
non-Fedora Core systems, but this is not a tool as much as a practice to adopt.

When do we need to regenerate a .POT file?

a. For every commit?
b. For every milestone that gets a CVS tag?

I have a feeling we are getting close to having a 'make cvs-commit' or some
fdpsh function. :)
Comment 8 Tommy Reynolds 2006-02-28 15:57:43 EST
The .POT file will be automatically regenerated every time the
${XMLFILES-${PRI_LANG} XML files are changed and *any* higher-level targets
(like make xml-${PRI_LANG} or make html-${PRI_LANG}) get executed.  There is
also a standalone "make pot" target.

My recommendation is to test the XML files by a "make html-${LANG}" test and
then CVS commit everything, just as we currently do.  Make sure that the .POT
file has been introduced to CVS, though.
Comment 9 Karsten Wade 2006-03-30 14:30:03 EST
Thanks for all the hard work on this, we're done for now, right?

Closing and all that.
Comment 10 eric@christensenplace.us 2009-07-07 00:09:33 EDT
Ticket moved to allow products to be removed from BZ.

Note You need to log in before you can comment on or make changes to this bug.