Bug 1798043 - [sriov] SR-IOV VFs are recreated when sriov-network-config-daemon pod restarts on host
Summary: [sriov] SR-IOV VFs are recreated when sriov-network-config-daemon pod restart...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 1798344
TreeView+ depends on / blocked
 
Reported: 2020-02-04 13:08 UTC by Peng Liu
Modified: 2020-05-04 11:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1798344 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:33:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 146 0 None closed BUG 1798043: Optimize VF configure logic 2020-02-24 02:07:18 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:33:36 UTC

Description Peng Liu 2020-02-04 13:08:31 UTC
Description of problem:
SR-IOV VFs are recreated when sriov-network-config-daemon pod restarts on host

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create sriovnetworknodepolicy with several VF defined.
2. Wait until the syncStatus of sriovnetworknodestate CR goes to 'Succeeded'.
3. Delete the sriov-network-config-daemon pod on the node with VF defined.

Actual results:
The existing VFs are deleted, then recreated.

Expected results:
The existing VFs are impacted by the sriov-network-config-daemon pod restart. 

Additional info:

Comment 1 Peng Liu 2020-02-04 13:51:43 UTC
Expected results:
The existing VFs are NOT impacted by the sriov-network-config-daemon pod restart.

Comment 3 zhaozhanqi 2020-02-05 09:49:54 UTC
verified this bug with image:
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.4.0-202002050701-ose-sriov-network-operator
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.4.0-202002050701-ose-sriov-network-config-daemon


# oc delete pod sriov-network-config-daemon-r5szr 
pod "sriov-network-config-daemon-r5szr" deleted
# oc rsh -n z1 testpod1jvtv9
sh-4.2# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: eth0@if78: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1450 qdisc noqueue state UP group default 
    link/ether 0a:58:0a:80:00:1d brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 10.128.0.29/23 brd 10.128.1.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::18e6:32ff:feab:8056/64 scope link 
       valid_lft forever preferred_lft forever
67: net1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 82:29:e0:65:ff:1c brd ff:ff:ff:ff:ff:ff
    inet 10.56.217.173/24 brd 10.56.217.255 scope global net1
       valid_lft forever preferred_lft forever
    inet6 fe80::8029:e0ff:fe65:ff1c/64 scope link 
       valid_lft forever preferred_lft forever


# oc logs sriov-network-config-daemon-d7lnx | grep "setSriovNumVfs"
#

Comment 5 errata-xmlrpc 2020-05-04 11:33:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.