Bug 17981 - wine rpm installs "dead" links
wine rpm installs "dead" links
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: wine (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 19:04 EDT by Hans Erickson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-02 17:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Erickson 2000-09-30 19:04:22 EDT
(Note:  This bug was filed under the component "redhat-release" because
"wine" did not show up in the list of components.)

When installing wine from the RedHat 7.0 install disk, it appears that some
files are missing.  The following is a transcript of an attempt to install
from the command line.
----------
[root@phobos RPMS]# rpm --install wine-20000725-2.i386.rpm 
/sbin/ldconfig: Input file /usr/lib/libwinspool.so not found.

/sbin/ldconfig: Input file /usr/lib/libwindebug.so not found.

/sbin/ldconfig: Input file /usr/lib/libwin87em.so not found.

/sbin/ldconfig: Input file /usr/lib/libwin32s.so not found.

/sbin/ldconfig: Input file /usr/lib/libmsacm.so not found.

----------

After this, doing a directory listing of /usr/lib indicates the following
"dead" links:
lrwxrwxrwx    1 root     root           15 Jun 11 01:35 libmsacm.so ->
libmsacm.so.1.0
lrwxrwxrwx    1 root     root           16 Jun 11 01:35 libwin32s.so ->
libwin32s.so.1.0
lrwxrwxrwx    1 root     root           17 Jun 11 01:35 libwin87em.so ->
libwin87em.so.1.0
lrwxrwxrwx    1 root     root           18 Jun 11 01:35 libwindebug.so ->
libwindebug.so.1.0
lrwxrwxrwx    1 root     root           18 Jun 11 01:35 libwinspool.so ->
libwinspool.so.1.0
Comment 1 Bill Nottingham 2000-10-02 17:18:23 EDT
This is most likely just a cosmetic issue of wine and
wine-devel both being installed, and the .soname changing
between the two packages.
Comment 2 Bernhard Rosenkraenzer 2000-10-12 14:34:01 EDT
Fixed in the current version (20001011).

Note You need to log in before you can comment on or make changes to this bug.