Bug 1798142 - EgressNetworkPolicy OpenAPI spec missing properties
Summary: EgressNetworkPolicy OpenAPI spec missing properties
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Aniket Bhat
QA Contact: huirwang
URL:
Whiteboard:
: 1812746 (view as bug list)
Depends On: 1769015
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 16:26 UTC by Jason Boxman
Modified: 2020-03-31 21:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 14:33:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 501 None closed Bug 1798142: Add preserveUnknownFields tag in the CRDs 2020-05-21 02:40:20 UTC
Red Hat Product Errata RHBA-2020:0858 None None None 2020-03-24 14:33:30 UTC

Description Jason Boxman 2020-02-04 16:26:47 UTC
Description of problem:

Hi,

```
For some reason, the OpenAPI spec for EgressNetworkPolicy does not have a `properties` key:

    "io.openshift.network.v1.EgressNetworkPolicy": {
      "type": "object",
      "x-kubernetes-group-version-kind": [
        {
          "group": "network.openshift.io",
          "kind": "EgressNetworkPolicy",
          "version": "v1"
        }
      ]
    },
```

This spec is part of the output from `oc get —raw /apis`. I’ve been using the OpenAPI spec file as the basis for the API documentation, so the the information for EgressNetworkPolicy I have is incomplete.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run `oc get —raw /apis`

Typically, they look like this:

```
    "io.k8s.api.extensions.v1beta1.NetworkPolicy": {
      "description": "DEPRECATED 1.9 - This group version of NetworkPolicy is deprecated by networking/v1/NetworkPolicy. NetworkPolicy describes what network traffic is allowed for a set of Pods",
      "type": "object",
      "properties": {
        "apiVersion": {
          "description": "APIVersion defines the versioned schema of this representation of an object. Servers should convert recognized schemas to the latest internal value, and may reject unrecognized values. More info: https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#resources",
          "type": "string"
        },
        "kind": {
          "description": "Kind is a string value representing the REST resource this object represents. Servers may infer this from the endpoint the client submits requests to. Cannot be updated. In CamelCase. More info: https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#types-kinds",
          "type": "string"
        },
        "metadata": {
          "description": "Standard object's metadata. More info: https://git.k8s.io/community/contributors/devel/sig-architecture/api-conventions.md#metadata",
          "$ref": "#/definitions/io.k8s.apimachinery.pkg.apis.meta.v1.ObjectMeta"
        },
        "spec": {
          "description": "Specification of the desired behavior for this NetworkPolicy.",
          "$ref": "#/definitions/io.k8s.api.extensions.v1beta1.NetworkPolicySpec"
        }
      },
```

Comment 8 errata-xmlrpc 2020-03-24 14:33:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858

Comment 9 Aniket Bhat 2020-03-31 21:54:19 UTC
*** Bug 1777707 has been marked as a duplicate of this bug. ***

Comment 10 Aniket Bhat 2020-03-31 21:57:01 UTC
*** Bug 1812746 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.