Bug 1798146 - DNS VIP missing from /etc/resolv.conf
Summary: DNS VIP missing from /etc/resolv.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.0
Assignee: Antoni Segura Puimedon
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks: 1797647
TreeView+ depends on / blocked
 
Reported: 2020-02-04 16:31 UTC by Marius Cornea
Modified: 2020-05-04 11:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1797647
Environment:
Last Closed: 2020-05-04 11:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1436 None closed Bug 1798146: [baremetal] Ipv6 non virtual ip fix 2020-06-23 10:04:36 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:33:29 UTC

Description Marius Cornea 2020-02-04 16:31:45 UTC
Clone for 4.4

+++ This bug was initially created as a clone of Bug #1797647 +++

Description of problem:
When deploying worker nodes in a bare metal IPv6 deployment /etc/resolv.conf doesn't include the DNS VIP hence the worker nodes do not come up properly.

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-01-29-114541-ipv6.1

How reproducible:
100%

Steps to Reproduce:
1. Deploy control plane IPv6 bare metal environment with worker nodes 

Actual results:
Worker nodes do not come up properly.

Expected results:
Worker nodes are set up correctly.

Additional info:

Comment 2 Dan Winship 2020-02-11 15:31:57 UTC
Can't currently be tested on 4.4. "Verifying" to unblock the backport.

Comment 4 errata-xmlrpc 2020-05-04 11:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.