Bug 1798182 - Operand tab order reversed on Installed Operators page
Summary: Operand tab order reversed on Installed Operators page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 18:24 UTC by Samuel Padgett
Modified: 2020-05-04 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-04-101704 Cluster ID: 30e82a96-378b-4183-a31f-4e87ca9b8663 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-05-04 11:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
correct-order-on-list-detail-column (98.21 KB, image/png)
2020-02-07 07:09 UTC, XiaochuanWang
no flags Details
correct-order-on-detail-page-header-scroll-line (40.75 KB, image/png)
2020-02-07 07:09 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4189 None closed Bug 1798182: Fix operand tab order 2020-04-17 17:53:41 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:33:29 UTC

Description Samuel Padgett 2020-02-04 18:24:47 UTC
The order of operand resource kinds is reversed from how it is declared in the ClusterServiceVersion YAML `spec.customresourcedefinitions.owned`

Regression from https://github.com/openshift/console/pull/3877

Comment 2 XiaochuanWang 2020-02-07 07:09:04 UTC
Created attachment 1661614 [details]
correct-order-on-list-detail-column

Comment 3 XiaochuanWang 2020-02-07 07:09:55 UTC
Created attachment 1661615 [details]
correct-order-on-detail-page-header-scroll-line

Comment 4 XiaochuanWang 2020-02-07 07:15:42 UTC
Now the order is correctly same as ClusterServiceVersion yaml order of `spec.customresourcedefinitions.owned`

Checked two places:
1) Installed Operators page for list column "Provided APIs" 
2) Operator "OpenShift Container Storage" detail page for header list scroll bar.

Attached screenshots for both two place.
Verified on 4.4.0-0.nightly-2020-02-06-230833

Comment 7 errata-xmlrpc 2020-05-04 11:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.