Bug 1798221 - OperatorHub is using the wrong default text as a call-to-action button [openshift-4.4]
Summary: OperatorHub is using the wrong default text as a call-to-action button [opens...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Rob Szumski
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-04 20:42 UTC by Rob Szumski
Modified: 2020-05-04 11:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:33:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4208 None closed Bug 1798221: Swap default text for marketplace CTA 2020-04-22 13:50:26 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:33:48 UTC

Description Rob Szumski 2020-02-04 20:42:50 UTC
Description of problem:
Incorrect "default" text is used within the OCP Console when linking to the Marketplace and a "action-text" string is not set.

Version-Release number of selected component (if applicable):
4.4.0-0.ci-2020-02-04-101704

How reproducible:
Load Marketplace catalog and attempt to install one

Steps to Reproduce:
1. Load Marketplace catalog
2. Browse to OperatorHub, filter to Marketplace in sidebar
3. Open detail page of an offering

Actual results:
See "View Details" main call to action

Expected results:
See "Purchase" main call to action

Additional info:
https://github.com/openshift/console/blob/d07c7dee623d54c00e95e8ba554c0fe6eba7f453/frontend/packages/operator-lifecycle-manager/src/components/operator-hub/operator-hub-items.tsx#L364

Comment 2 Yanping Zhang 2020-02-10 14:32:45 UTC
Tested on OCP 4.0 env with payload 4.4.0-0.nightly-2020-02-09-220310.
Checked that there was no marketplace.openshift.io/action-text annotation for crd "cockroachdb-certified-rhmp", click CockroachDB operator in OperatorHub, on the cockroachdb page, the button text is "Purchase" now.
The bug is fixed.

Comment 4 errata-xmlrpc 2020-05-04 11:33:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.