Bug 1798288 - Service binding should be through Knative Service
Summary: Service binding should be through Knative Service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jaivardhan Kumar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1808968
TreeView+ depends on / blocked
 
Reported: 2020-02-05 04:37 UTC by Jaivardhan Kumar
Modified: 2020-05-04 11:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Service binding request in topology is associated with Revisions in topology view Consequence: no new revision will get the associated secrets Fix: SBR should go through knative service secrets would be injected and in turn new revisions would be created Result: SBR works as expected with Knative Service
Clone Of:
: 1808968 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:33:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4196 None closed Bug 1798288: fixes sbr to work with knative service 2020-04-20 11:31:56 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:33:48 UTC

Description Jaivardhan Kumar 2020-02-05 04:37:05 UTC
Description of problem:

Currently, on hover on Revisions, we show connector which can be dropped to an Operator backed service which in turn creates Service Binding Request which is incorrect sbr should be created via knative service and in turn revisions should be rolled out

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install OpenShift Serverless operator
2. Create a knative service with DevConsole Add flow
3. Install Service binding operator
4. Install Postgress operator and create an instance of a database
5. Go topology view and hover on revisions under knative service, should show a connector and can be dropped to a database instance created above

Actual results:
Currently, on hover on Revisions, we show connector which can be dropped to an Operator backed service which in turn creates Service Binding Request.

Expected results:
Service Binding Request would be from knative Service i.e on hover for knative service show connector which can be dropped to an Operator backed service which in turn creates Service Binding Request and inject required info in service.

Comment 2 Gajanan More 2020-03-02 11:25:05 UTC
https://issues.redhat.com/browse/ODC-2791 verified by Sahil Budhwar

Comment 4 errata-xmlrpc 2020-05-04 11:33:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.