Bug 179834 - run-mozilla.sh can't find core files
Summary: run-mozilla.sh can't find core files
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-03 09:48 UTC by Paul Dickson
Modified: 2018-04-11 09:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Dickson 2006-02-03 09:48:42 UTC
Description of problem:
/usr/lib/firefox-1.5.0.1/run-mozilla.sh is looking for a core file named "core",
not "core.<proc-id>".


Version-Release number of selected component (if applicable):
firefox-1.5.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. ulimit -c unlimited
2. DEBUG_CORE_FILES=1 firefox --safemode
3. Load http://simonbaird.com/mptw1/
4. Click on Minesweep in left-side column
  
Actual results:
After core dumping, a new commandline prompt is reached.

Expected results:
<After core dump>

Oh no!  /usr/lib/firefox-1.5.0.1/firefox-bin just dumped a core file.

Do you want to debug this ? You need a lot of memory for this, so watch out ? [y/n]

Additional info:
The cause of this core dump has something with assign global variables in
Javascript (see http://groups.google.com/group/TiddlyWiki, thread "FireFox
1.5.0.1 Dumps with Tiddlywiki 1.2.x"), but this isn't really relevant to this 
bug report (it happens on the windows version of firefox 1.5.0.1 too).

I worked around this bug temporarily by inserting "mv core.* core" at line 168
of run-mozilla.sh.

Comment 1 Matěj Cepl 2007-12-20 16:47:57 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.