Bug 179838 - Add OptionalRequires: in rpm structure so rpm --suggest option could be added
Summary: Add OptionalRequires: in rpm structure so rpm --suggest option could be added
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-03 10:24 UTC by Olivier Lahaye
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.4.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 14:05:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Lahaye 2006-02-03 10:24:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Maxthon; .NET CLR 1.1.4322)

Description of problem:
Add OptionalRequires: in rpm spec structure so rpm --suggest option could be added

Example:
rpm -i kbarcode would install only kbarcode (provided that dependancies are satified)

rpm -i --suggest kbarcode would require optional packages to be istalled like mysql,PDF417 Encode and TBarcode. those packages are not required for kbarcode to have basic functionalities, but are used if installed.

Same for k3b: rpm -i --suggest k3b would require transcode to be installed. while this package is not mandatory for k3b to function properly, if istalled, it enhances k3b features.

in the spec file, a line like
OptionalRequires: transcode
would be added.

Version-Release number of selected component (if applicable):
any

How reproducible:
Always

Steps to Reproduce:
1. # rpm --suggest k3b
  

Actual Results:  Error messages recieved:
--suggest: unknown option


Expected Results:  # rpm -i --suggest k3b
error: Failed dependencies:
        transcode is required for k3b-0.11.20-1

or

# rpm -i --suggest k3b
error: Failed dependencies:
        transcode is suggested for k3b-0.11.20-1


Additional info:

Comment 1 Olivier Lahaye 2006-02-03 14:05:07 UTC
Oups seems to be already implemented into rpm-4.4.4.



Note You need to log in before you can comment on or make changes to this bug.