Bug 1798481 - Preserve choice of list view when navigating back
Summary: Preserve choice of list view when navigating back
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-05 13:13 UTC by Vikram Raj
Modified: 2020-05-04 11:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.3.0-0.ci-2020-01-29-133443 Cluster ID: d336ec03-6b3f-437f-8f0b-8ca8a5143aa7 Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.79 Safari/537.36
Last Closed: 2020-05-04 11:33:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4206 0 None closed Bug 1798481: Preserve choice of list view when navigating back 2020-04-22 18:40:48 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:34:00 UTC

Description Vikram Raj 2020-02-05 13:13:25 UTC
Description of problem:

When in the topology view, I switch to the list view, I then navigate to a resource, then I select topology...I would like to still be in the list view but it puts me in the graph view.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Navigate to topology view and switch to list page. 
2. Then navigate to pod detail page by clicking on the pod.
3. Navigate to topology page clicking on nav menu from the side bar. 

Actual results:
Take you to topology page even when you navigate to resource page from the list view of topology

Expected results:
Should take you to topology list view page when you navigate to resource page from the list view of topology.


Additional info:

Comment 3 Gajanan More 2020-03-02 07:18:18 UTC
Verified by Aritra Roy 
Equivalent Jira: https://issues.redhat.com/browse/ODC-2929

Comment 4 Gajanan More 2020-03-02 11:34:56 UTC
https://issues.redhat.com/browse/ODC-2929 verified by Aritra

Comment 6 errata-xmlrpc 2020-05-04 11:33:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.