Bug 1798498 - [Edge] installer gather bootstrap doesn't gather IP's for baremetal
Summary: [Edge] installer gather bootstrap doesn't gather IP's for baremetal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Stephen Benjamin
QA Contact: Elena German
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-05 13:58 UTC by Elena German
Modified: 2020-07-13 17:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The installer did not know the IP's for the control plane or bootstrap. Consequence: The installer was unable to gather logs on bootstrap failure. Fix: Extract IP information from terraform introspection data. Result: The installer now gathers logs on bootstrap failure for baremetal IPI.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:14:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3617 0 None closed Bug 1798498: gather: enable bootstrap log gathering for baremetal 2020-10-28 08:44:11 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:14:28 UTC

Description Elena German 2020-02-05 13:58:58 UTC
Description of problem:
installer gather bootstrap doesn't work for baremetal, ignore provided host ip and fails

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.Run IPI baremetal deployment, wait until a bootstrap node will be created 
2.Could stop deployment
3.$./openshift-baremetal-install gather bootstrap  --bootstrap <bootstrap-ip> --dir <myclusterinstall_dir>

Actual results:
FATAL bootstrap host address and at least one control plane host address must be provided 

Expected results:
log-bundle tar.gz file should be written to myclusterinstall_dir

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Stephen Benjamin 2020-02-24 14:52:21 UTC
install-gather requires you give the bootstrap IP and at least one of the control plane host IP's, as explained in the error you received:

   FATAL bootstrap host address and at least one control plane host address must be provided 

That's not really a bug in itself. However, baremetal doesn't support automatic gathering of any of the IP's yet. We can consider that something that needs to be fixed (and there's an upstream issue https://github.com/openshift/installer/issues/2009).

Comment 5 Elena German 2020-07-02 17:04:51 UTC
done

Comment 7 errata-xmlrpc 2020-07-13 17:14:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.