Bug 1798551 - It is possible to specify a compute profile without any attributes in a hostgroup
Summary: It is possible to specify a compute profile without any attributes in a hostg...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Group
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Yifat Makias
QA Contact: Omkar Khatavkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-05 15:11 UTC by Lukáš Hellebrandt
Modified: 2021-07-09 17:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-09 17:02:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 32924 0 Normal New It is possible to specify a compute profile without any attributes in a hostgroup 2021-07-01 08:55:28 UTC

Description Lukáš Hellebrandt 2020-02-05 15:11:56 UTC
Description of problem:
In Hammer, it is possible to select any compute profile for a hostgroup. However, in WebUI, it is only possible to select a compute profile that has attributes for at least one compute resource (i.e. is not shown as "unspecified" when open through Infrastructure -> Compute Profiles -> <compute_profile>). Furthermore, when selecting a compute profile through Hammer that would be hidden in WebUI, that compute profile is then shown in WebUI when editing that (and only that!) hostgroup.

Version-Release number of selected component (if applicable):
6.7, not a regression (new feature)

How reproducible:
Deterministic

Steps to Reproduce:
1. hammer hostgroup {create,update} ... --compute-profile-id <ID_of_a_profile_without_attributes_for_any_CR>

Actual results:
Compute profile selected. Compute profile shown in WebUI for that hostgroup.

Expected results:
Unable to select that compute profile, consistently with WebUI.

Comment 3 Tomer Brisker 2021-07-01 08:55:26 UTC
Created redmine issue https://projects.theforeman.org/issues/32924 from this bug

Comment 4 Bryan Kearney 2021-07-04 12:03:37 UTC
Upstream bug assigned to ymakias

Comment 5 Bryan Kearney 2021-07-04 12:03:41 UTC
Upstream bug assigned to ymakias

Comment 6 Bryan Kearney 2021-07-06 12:04:10 UTC
Moving this bug to POST for triage into Satellite since the upstream issue https://projects.theforeman.org/issues/32924 has been resolved.

Comment 7 Mike McCune 2021-07-09 17:02:24 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this feel free to contact your Red Hat Account Team. Thank you.


Note You need to log in before you can comment on or make changes to this bug.