Bug 1798622 - oc adm release info --changelog does not escape html
Summary: oc adm release info --changelog does not escape html
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-05 17:11 UTC by Eric Paris
Modified: 2020-05-13 21:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:56:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 281 None closed Bug 1798622: oc adm release info: escape PR titles which might contain html 2020-04-22 09:56:48 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:56:19 UTC

Description Eric Paris 2020-02-05 17:11:18 UTC
For example if you run:
oc adm release info --changelog=/home/eparis/go/src/ --changes-from=quay.io/openshift-release-dev/ocp-release:4.2.16-x86_64 registry.svc.ci.openshift.org/ocp/release:4.3.0-0.ci-2020-02-04-004213

you will see that the output includes <title> in some of the lines

If you run with this fixed you should instead see:
&lt;title&gt

Comment 2 zhou ying 2020-02-11 03:25:17 UTC
Confirmed with latest oc client, can't reproduce the issue now:
[root@dhcp-140-138 tmp]#  oc version -o yaml 
clientVersion:
  buildDate: "2020-02-10T17:21:47Z"
  compiler: gc
  gitCommit: ee05f83cb8f0bee84c0a1516591437cd71befdc8
  gitTreeState: clean
  gitVersion: v4.4.0
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

Comment 4 errata-xmlrpc 2020-05-13 21:56:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.