Bug 179877 - RFE: support multiple commands on command line
RFE: support multiple commands on command line
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ethtool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 11:10 EST by Tom "spot" Callaway
Modified: 2013-07-02 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 15:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add ETHTOOL_PAUSE_OPTS handing (1.38 KB, patch)
2006-02-03 11:10 EST, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Tom "spot" Callaway 2006-02-03 11:10:23 EST
Description of problem:

Currently, there is no easy way similar to ETHTOOL_OPTS in ifcfg-eth* to
automatically configure pause control. ETHTOOL_OPTS in ifup-eth always uses
"ethtool -s", but to do flow control, we really want a second invocation of
"ethtool -A ...". 

This is a trivial item to fix, it involves the creation of ETHTOOL_PAUSE_OPTS,
and handling it in ifup-eth the same way as ETHTOOL_OPTS. Patch is attached to
this bug ticket.
Comment 1 Tom "spot" Callaway 2006-02-03 11:10:23 EST
Created attachment 124108 [details]
add ETHTOOL_PAUSE_OPTS handing
Comment 3 Bill Nottingham 2006-02-03 11:34:00 EST
Hm, but what if someone then wants to change the -G settings, etc - another
commandline option and invocation?

Perhaps we can... convince... the ethtool upstream to allow multiple commands on
the command line.
Comment 4 Tom "spot" Callaway 2006-02-03 11:44:24 EST
That would also be an acceptable approach.
Comment 5 Bill Nottingham 2006-02-03 11:56:57 EST
Pushing to ethtool for the moment - allowing multiple commands on the command
line would make this much simpler.
Comment 6 Jon Stanley 2008-04-23 16:29:23 EDT
Adding FutureFeature keyword to RFE's.
Comment 9 Jeff Garzik 2008-08-21 15:35:29 EDT
To repeat the answer that has been repeated since 2002:

ethtool utility is a small, lightweight utility that has a 1-1 correspondence between ethtool commands and the ethtool ioctls it issues to the kernel. (some of 'list' commands excepted)  A single ethtool invocation performs a single ethtool ioctl.

Inside the kernel, a single ethtool ioctl is the smallest unit of atomicity available.  The userspace utility matches that interface.

If you want to issue multiple ioctls, fix your infrastructure to perform multiple ethtool(1) invocations.

A simple, looping shell script will easily solve this bug.  If it makes people happy, call this script "ethtool-multi".

Note You need to log in before you can comment on or make changes to this bug.