Bug 1798851 - [UI][Operator] Subscribe disabled when Update Channel changed in Create Operator Subscription
Summary: [UI][Operator] Subscribe disabled when Update Channel changed in Create Opera...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1798855 1836332 (view as bug list)
Depends On:
Blocks: 1809313
TreeView+ depends on / blocked
 
Reported: 2020-02-06 07:01 UTC by Takayoshi Kimura
Modified: 2020-07-13 17:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When user changed the "Update Channel" in the Create Operator Subscription form the target namesoace where the subscription is installed was cleared out. Consequence: User was unable to submit the form even if it was filled out. Fix: Remove logic that clears the target namespace Result: User is able to submit the form if the "Update Channel" is changed after the form is filled out.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4374 None closed Bug 1798851: Dont set the targetNamespace when changing update channel 2020-08-20 11:42:01 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:32 UTC

Description Takayoshi Kimura 2020-02-06 07:01:14 UTC
Description of problem:

Namespace selection ignored when Update Channel changed in Create Operator Subscription page. The "Subscribe" button get disabled and grayed out when Update Channel changed. When re-select namespace the "Subscribe" button back to normal, so it seems the namespace field needs re-selected, but no UI feedback.

Version-Release number of selected component (if applicable):

OpenShift 4.3.0

How reproducible:

Always

Steps to Reproduce:
1. Try to install Cluster Logging Operator, go to Create Operator Subscription page
2. Select namespace
3. Change Update Channel, all required fields filled out at this point
4. "Subscribe" button disabled
5. Re-select namespace, it re-enables "Subscribe" button 

Actual results:

"Subscribe" button disabled with no UI feedback

Expected results:

The "Subscribe" button should be enabled once all information filled out. Or clear namespace field on Update Channel changes if needed.

Additional info:

Comment 1 Robb Hamilton 2020-02-18 16:34:46 UTC
The key to reproducing is for the project selector being set to "all projects" before installing an operator (the bug does not reproduce if the project selector is set to a specific project).

Comment 2 Jakub Hadvig 2020-03-02 16:22:37 UTC
*** Bug 1798855 has been marked as a duplicate of this bug. ***

Comment 5 shahan 2020-03-03 07:58:00 UTC
The console would not reset the taget namespaces when install all-namespaced operators.
4.5.0-0.ci-2020-03-03-065123

Comment 6 Robb Hamilton 2020-05-21 12:01:37 UTC
*** Bug 1836332 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2020-07-13 17:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.