Bug 1798858 - Installed Operators list page show an empty status when status.phase is Installing
Summary: Installed Operators list page show an empty status when status.phase is Insta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1803935 1804604
TreeView+ depends on / blocked
 
Reported: 2020-02-06 07:15 UTC by Yadan Pei
Modified: 2020-05-04 11:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1803935 1804604 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:34:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
Empty Status (78.80 KB, image/png)
2020-02-06 07:16 UTC, Yadan Pei
no flags Details
Show Installing on Operator Details (435.49 KB, image/png)
2020-02-06 07:20 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4270 None closed Bug 1798858: Fix bug where installed operators list status is missin… 2020-04-29 21:31:23 UTC
Github openshift console pull 4327 None closed Bug 1798858: follow on code cleanup 2020-04-29 21:31:23 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:34:34 UTC

Description Yadan Pei 2020-02-06 07:15:27 UTC
Description of problem:
When operator is in the Status of Installing, Installed Operators page show an empty Status

Version-Release number of selected component (if applicable):
upgraded to 4.4.0-0.nightly-2020-02-05-220946

How reproducible:
ALways

Steps to Reproduce:
1. subscribe operator to all/one namespace, such as install Metering operator to 'openshift-metering' namespace
2. Monitor operator status at Operator Details page or CLI
$ while true; do oc get csv -n openshift-metering  | grep metering; oc get csv metering-operator.4.3.1-202001310552 -n openshift-metering -o json | jq '.status.phase'; done
metering-operator.4.3.1-202001310552        Metering                  4.3.1-202001310552              Installing
"Installing"
metering-operator.4.3.1-202001310552        Metering                  4.3.1-202001310552              Installing
"Installing"
metering-operator.4.3.1-202001310552        Metering                  4.3.1-202001310552              Installing
"Installing"
metering-operator.4.3.1-202001310552        Metering                  4.3.1-202001310552              Installing
"Installing"
metering-operator.4.3.1-202001310552        Metering                  4.3.1-202001310552              Installing
3. Monitor operator status at Installed Operators page

Actual results:
3. It show an empty Status(only up to date message) when operator is Installing

Expected results:
3. It shows 'Installing' status to be consistent with Operator Details page and CLI output

Additional info:

Comment 1 Yadan Pei 2020-02-06 07:16:25 UTC
Created attachment 1658099 [details]
Empty Status

Comment 2 Yadan Pei 2020-02-06 07:20:13 UTC
Created attachment 1658101 [details]
Show Installing on Operator Details

Comment 3 Yadan Pei 2020-02-06 07:33:28 UTC
When status.phase is Pending, it also show an empty Status on Installed Operators list page

Comment 7 Yadan Pei 2020-02-17 09:10:11 UTC
Now Installed Operators list page show correct status of Operators, it shows the progress Pending -> Install Ready -> Installing -> Succeeded as in CLI

Verified on     4.4.0-0.nightly-2020-02-16-205302

Comment 9 errata-xmlrpc 2020-05-04 11:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.