Bug 1798865 - Storage: Volume snapshot in PVC's detail page show Error: 404: Page Not Found
Summary: Storage: Volume snapshot in PVC's detail page show Error: 404: Page Not Found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: afrahman
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-06 07:52 UTC by Liang Xia
Modified: 2020-05-04 11:34 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Snapshot is not supported for all PVC and hence tab does not show any useful information Consequence: 404 error occurs due to absence of required CRs Fix: Gated the snapshot functionality to show Volume snapshot tab for supported ceph provisioned PVCs Result: The tab is not visible for PVC that cannot be snapshot.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:34:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
volume-snapshot-error (72.71 KB, image/png)
2020-02-06 07:52 UTC, Liang Xia
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4290 None closed Bug 1798865: Volume snapshot in PVC's detail page show Error: 404: Page Not Found 2020-04-28 05:40:48 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:34:34 UTC

Description Liang Xia 2020-02-06 07:52:21 UTC
Created attachment 1658104 [details]
volume-snapshot-error

Description of problem:
Go to PVC details page, and switch to tab "Volume Snapshots".
it shows Error:404:Page Not Found


Version-Release number of selected component (if applicable):
OpenShift Version 4.4.0-0.nightly-2020-02-04-171905

How reproducible:
Always

Steps to Reproduce:
1. Create a PVC.
2. Login to admin console.
2. Go to PVC details page, and switch to tab "Volume Snapshots".
3.

Actual results:
It shows Error:404:Page Not Found

Expected results:
Proper info or content show up.


Additional info:
Refer to "volume-snapshot-error.png"

Comment 3 Liang Xia 2020-02-14 05:51:31 UTC
Verified the issue is fixed in OpenShift Version 4.4.0-0.nightly-2020-02-13-212616

Comment 5 errata-xmlrpc 2020-05-04 11:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.