Bug 17989 - "/" put on wrong part of disk, lilo/boot fails
"/" put on wrong part of disk, lilo/boot fails
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-30 23:56 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-05 18:17:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-30 23:56:40 EDT
Relevant part of the kickstart config file:

	clearpart --all
	zerombr yes
	part / --size=256 --ondisk=sda
	part swap --size=1024 --ondisk=sda
	part /usr --size=2024 --ondisk=sda
	part /var --size=1024 --ondisk=sda
	part /tmp --size=512 --ondisk=sda
	part /home --size=1024 --ondisk=sda
	part /opt --size=1024 --ondisk=sda --grow
	part /opt/content --ondisk=sdb --grow

What I get is an sda ordered by what looks like reverse size order.  /usr
appears first,
and so on, down to / on sda8, which is also at the very end of the disk. 
lilo complains about
this and RHL fails to boot.

Harware in question:
	VA Linux box
	On-board Adaptec controller
	Two 18G UltraSCSI drives.

What gives?

						- Marc David Rovner
						  [ ] ( ) / \ . com
Comment 1 Michael Fulbright 2000-10-02 18:37:47 EDT
Brock please verify.
Comment 2 Brock Organ 2000-11-03 11:13:29 EST
verified this behavior in both 6.2 & 7 ... thanks for your report!
Comment 3 Steven Roberts 2001-02-05 02:25:43 EST
Based on some readin via Deja, it appears anaconda uses a reverse disk size sorting (takes biggest parition first and lays it down).

the deja article that talks about how to get around this using --grow and --maxsize:
http://x66.deja.com/getdoc.xp?AN=607131878&CONTEXT=981352670.1271201875&hitnum=1

Still haven't found a way to get around the problem reported in bugs 11698/20221
Comment 4 Michael Fulbright 2001-03-05 18:17:13 EST
I believe I have fixed this - a quick test showed that '/' is now put first.

Note You need to log in before you can comment on or make changes to this bug.