Bug 1798947 - Random failure on NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED when creating team interface
Summary: Random failure on NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED when ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: 8.2
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: nmstate-nm
TreeView+ depends on / blocked
 
Reported: 2020-02-06 11:31 UTC by Gris Ge
Modified: 2020-04-28 16:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:54:14 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
team0_up.yml (55 bytes, text/plain)
2020-02-06 11:31 UTC, Gris Ge
no flags Details
team0_absent.yml (59 bytes, text/plain)
2020-02-06 11:32 UTC, Gris Ge
no flags Details
System logs with NM trace enabled (88.25 KB, text/plain)
2020-02-06 11:32 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:54:36 UTC

Description Gris Ge 2020-02-06 11:31:02 UTC
Description of problem:

Got failure when creating team interface via nmstatectl.

2020-02-06 17:54:00,729 root         ERROR    NM main-loop aborted: Connection activation failed on team0: reason=<enum NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED of type NM.ActiveConnectionStateReason>


Version-Release number of selected component (if applicable):
NetworkManager-team-1.22.6-1.el8.x86_64
teamd-1.29-1.el8.x86_64
libteam-1.29-1.el8.x86_64
nmstate-0.2.3-1.el8.noarch

How reproducible:
1%

Steps to Reproduce:

for x in `seq 1 100`; do
    sudo ncl set team0_up.yml && \
    sudo ncl set team0_absent.yml && \
    sleep 1 || \
    break;
    echo $x;
done;
echo $x;

Actual results:
Got failure of NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED

Expected results:
No failure

Additional info:
At the time this failure happens, I used:

nm_dev = NM.Client.get_device_by_iface(devname)
new_ac = nm_dev.get_active_connection()

The new_ac is identical to current NM.ActiveConnection.

Comment 1 Gris Ge 2020-02-06 11:31:54 UTC
Created attachment 1658144 [details]
team0_up.yml

Comment 2 Gris Ge 2020-02-06 11:32:21 UTC
Created attachment 1658155 [details]
team0_absent.yml

Comment 3 Gris Ge 2020-02-06 11:32:55 UTC
Created attachment 1658156 [details]
System logs with NM trace enabled

Comment 9 Vladimir Benes 2020-02-21 12:13:30 UTC
covered by the nmstate test executing nmstate's CI.

Comment 11 errata-xmlrpc 2020-04-28 16:54:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.