Bug 17990 - anaconda error during installation
anaconda error during installation
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 00:04 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 01:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text file created by installer (1.13 KB, text/plain)
2000-10-01 00:06 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-01 00:04:06 EDT
This bug causes the installer (both text and graphical) to exit just before
performing file installation, but after installation drive has been
formatted.  I am using the downloaded RH7 iso image that I got from tucows
on a Compaq Deskpro EN 400.

error text follows {

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in
systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] +
\
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in
filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' +
mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')
 
Local variables in innermost frame:
fsystem: /mnt/sysimage//win
 
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6
 
<failed>

} end of error text

I'd be more than happy to help in any way possible to resolve this bug.

Mike Ball
mike_ball@hotmail.com
Comment 1 Need Real Name 2000-10-01 00:06:02 EDT
Created attachment 3578 [details]
text file created by installer
Comment 2 Alan Cox 2000-10-01 18:13:23 EDT

*** This bug has been marked as a duplicate of 18032 ***
Comment 3 Need Real Name 2000-10-05 19:38:38 EDT
Work-around worked.  I didn't mount the win partition at install and the install
completed successfully this time.

Note You need to log in before you can comment on or make changes to this bug.