Bug 1799057 - Send apiserver request-in-flight metrics to telemeter
Summary: Send apiserver request-in-flight metrics to telemeter
Keywords:
Status: CLOSED DUPLICATE of bug 1798214
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Abu Kashem
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1798214
Blocks: 1798215
TreeView+ depends on / blocked
 
Reported: 2020-02-06 14:37 UTC by Abu Kashem
Modified: 2020-03-05 08:58 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1798214
Environment:
Last Closed: 2020-03-05 08:58:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 643 0 None closed Bug 1799057: Send apiserver_current_inflight_requests in telemeter. 2021-01-22 11:29:04 UTC

Comment 4 Abu Kashem 2020-02-10 15:49:14 UTC
Hi juzhao@redhat.com, surbania@redhat.com
I have followed the guidelines in this doc - https://docs.google.com/document/d/1a6n5iBGM2QaIQRg9Lw4-Npj6QY9--Hpx3XYut-BrUSY/edit#heading=h.xynschki97ew

"Open a PR against cluster-monitoring-operator with the above changes.
At the next deployment of the telemetry backend the newly added metrics will be whitelisted."

According to Team Monitoring the process has been simplified, all I need to do is open a PR in cluster-monitoring-operator repo. If this is not true can you please send me instructions on how to add this to the telemeter server.

Comment 5 Lili Cosic 2020-02-10 15:53:41 UTC
Ah I know the problem here, yes the telemeter server side has not been synced yet. Waiting until that happens and then we can reverify. Nothing for you Abu to do here.

Comment 6 Ke Wang 2020-03-05 08:58:03 UTC
Duplicated to bug 1798214.

*** This bug has been marked as a duplicate of bug 1798214 ***


Note You need to log in before you can comment on or make changes to this bug.