Bug 1799222 - chocolate-doom: FTBFS in Fedora rawhide/f32 [NEEDINFO]
Summary: chocolate-doom: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chocolate-doom
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rahul Sundaram
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-02-06 16:13 UTC by Fedora Release Engineering
Modified: 2020-03-27 08:01 UTC (History)
2 users (show)

Fixed In Version: chocolate-doom-3.0.0-5.fc32
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-27 08:01:36 UTC
Type: ---
releng: needinfo? (metherid)


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2020-02-06 16:13 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2020-02-06 16:14 UTC, Fedora Release Engineering
no flags Details
state.log (1014 bytes, text/plain)
2020-02-06 16:14 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 16:13:52 UTC
chocolate-doom failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41316160


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix chocolate-doom at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
chocolate-doom will be orphaned. Before branching of Fedora 33,
chocolate-doom will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 16:13:55 UTC
Created attachment 1658584 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2020-02-06 16:14:00 UTC
Created attachment 1658585 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 16:14:05 UTC
Created attachment 1658586 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 17:13:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:25:31 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Jordan Christiansen 2020-02-25 04:51:13 UTC
I'm a drive-by contributor who just noticed that chocolate-doom isn't in the Fedora Packages search results.

From the build logs, this is the failure:

/usr/bin/ld: hexen/libhexen.a(g_game.o):(.bss+0x944): multiple definition of `demoextend'; hexen/libhexen.a(mn_menu.o):(.bss+0x34): first defined here

I'm not sure why this is failing now when the sources haven't changed.

Comment 7 Fedora Release Engineering 2020-03-01 04:25:18 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 8 Fedora Release Engineering 2020-03-08 04:25:35 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 32.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (that's on 2020-04-02).

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-33/f-33-key-tasks.html

Comment 9 Jordan Christiansen 2020-03-13 02:46:05 UTC
This problem is caused by the upgrade to GCC 10. The new GCC version defaults to -fno-common, which causes the linker to fail when there are multiple definitions of a global variable. Hexen defines the global demoextend in both src/hexen/g_game.c and src/hexen/mn_menu.c. I'll work on a patch to fix this. It's also possible to explicitly set the -fcommon flag to work around the issue.

Comment 10 Jordan Christiansen 2020-03-15 22:48:18 UTC
I submitted a patch that fixes this to upstream. https://github.com/chocolate-doom/chocolate-doom/pull/1257

What's the best way to make sure that this makes it into Fedora 32? If upstream accepts the patch and cuts a release can we use that version in 32? Or do we need to carry a patch downstream?

Comment 11 Jordan Christiansen 2020-03-19 17:50:57 UTC
My patch was accepted upstream and is now on master.

Comment 12 Fedora Update System 2020-03-20 01:59:15 UTC
chocolate-doom-3.0.0-5.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7feeffda7b

Comment 13 Fedora Update System 2020-03-27 08:01:36 UTC
FEDORA-2020-7feeffda7b has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.