Bug 1799313 - OpenstackSDK not used in whole kuryr-kubernets project.
Summary: OpenstackSDK not used in whole kuryr-kubernets project.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: rdobosz
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-06 16:32 UTC by rdobosz
Modified: 2020-05-13 21:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:56:40 UTC
Target Upstream Version:
gcheresh: needinfo+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 156 None closed Bug 1799313: Rebase from upstream 2020-09-14 10:53:18 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:56:41 UTC

Description rdobosz 2020-02-06 16:32:02 UTC
Description of problem:
Recently there was a switching from neutron client to the openstacksdk client, although not all components were successfully converted.


Version-Release number of selected component (if applicable):
4.4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
All of the components switched to openstacksdk, or at least drivers which are currently not possible to move, isolate within the modules.

Additional info:

Comment 1 Michał Dulko 2020-02-06 16:34:42 UTC
Worth to say that it may lead to undefined behaviors - e.g. some code doesn't handle exceptions from python-neutronclient anymore.

Comment 3 GenadiC 2020-03-03 13:07:26 UTC
Please provide steps to reproduce this - it's too general

Comment 4 GenadiC 2020-03-03 13:07:50 UTC
Please provide steps to reproduce this - it's too general

Comment 5 rdobosz 2020-03-03 13:33:30 UTC
From user perspective, it's kind of undistinguishable from previous implementation - it is rather an improvement for code maintenance and being able to keep up with changes to the API/clients in one place.

What is affected by this change:

- handlers:
  - namespace
  - kuryrnet
  - vif
  - lbaas

- drivers:
  - all but macvlan nested driver

Comment 6 rdobosz 2020-03-05 12:21:17 UTC
Effectively, for confirmation it's enough to run tempest tests against those patches.

Comment 7 Itzik Brown 2020-04-05 11:30:14 UTC
Verified with the following:
4.4.0-0.nightly-2020-04-04-025830

Comment 9 errata-xmlrpc 2020-05-13 21:56:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.