Bug 179952 - pirut should not automatically quit
pirut should not automatically quit
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 19:53 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 11:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2006-02-03 19:53:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
I think it would be more useful if pirut didn't automatically quit after hitting the completing a transaction. I don't know if this is eventually planned for or not.

In using it today, adding and removing a few packages in one transaction caused some dep problems. I then tried proceeding in smaller chunks but having to restart pirut after each step was less than optimal. I realize broken deps may be less of a problem when we're not dealing with rawhide, but I don't really see a reason to force a user to build one big transaction instead of being able to do it in smaller pieces.

Version-Release number of selected component (if applicable):
pirut-0.9.8-1

How reproducible:
Always

Steps to Reproduce:
1. install something with pirut
2.
3.
  

Actual Results:  After installing, it quits.

Expected Results:  It should stay running in case I want to install or remove something else.

Additional info:
Comment 1 Jeremy Katz 2006-02-06 11:43:21 EST
The problem is that by doing installs, it basically invalidates the set of
information we have and we'd have to do a lot of rechecking.  

Note You need to log in before you can comment on or make changes to this bug.