Bug 179972 - Printer settings not remembered across reboots
Printer settings not remembered across reboots
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 22:54 EST by Robert Walsh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 11:48:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from "printconf-tui --Xexport" (3.17 KB, text/xml)
2006-02-11 15:53 EST, Robert Walsh
no flags Details

  None (edit)
Description Robert Walsh 2006-02-03 22:54:07 EST
Description of problem:
When I used printconf (usually the GUI version) to configure a local printer, it
works fine until I reboot.  Then I have to redo the whole thing again.  For
example, I have to mark the printer as "shared", configure the paper size, DPI
settings, etc.  Some settings I don't have to redo: the printer driver, for example.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.131.3-1
cups-1.1.23-15.3

How reproducible:
Happens every single time for me.

Steps to Reproduce:
1. Set up a printer with printconf.  Set it to shared.  Change something like
the DPI or paper size.
2. Reboot.
3. Look at the printer settings in printconf.
  
Actual results:
Certain settings (DPI, paper size, shared status are the ones I usually change)
have been reset back to their default settings.

Expected results:
The settings should be the same as before.

Additional info:
Comment 1 Tim Waugh 2006-02-07 10:44:41 EST
Please attach the output of 'printconf-tui --Xexport'.  Thanks.
Comment 2 Robert Walsh 2006-02-11 15:53:40 EST
Created attachment 124546 [details]
Output from "printconf-tui --Xexport"

Well, this is very odd.  I've attached the file, but ever since I've run this
command, the settings have "stuck" and are now kept over reboots.  This is the
first time in dozens of reboots I've seen this behavior.  Is it possible that
running this command somehow made things permanent?
Comment 3 Robert Walsh 2006-02-11 16:07:35 EST
So, I tried an experiment.  I changed some settings and rebooted.  This time, it
worked again - the changes stuck.  Ever since I've run the command you
suggested, everything is working OK.  I've no explanation for this at all.

I definitely wasn't imagining things before: my wife would frequently complain
that she couldn't print from her machine, and this always happened after a
reboot.  A check of the settings always showed them all reset back to their old
values.  Honestly!  I wasn't halucinating.

One point to note is that I've always made changes logged in as my user id, and
so had to enter the root password in administrative privilages dialog box.  When
I ran the "printconf-tui --Xexport" command, I did it from a terminal where I
had already su'd to root, so wasn't asked for a password.  However, I did
accidently type "printconf-tui -Xexport" instead (single dash), which brought up
the TUI dialog box.  I thought I'd mention it just in case it had any side effects.
Comment 4 Tim Waugh 2006-12-13 11:48:59 EST
The system-config-printer tool was re-written for FC6, and that has fixed a lot
of problems like this.  Please re-open if this occurs again in FC6 or newer.

Note You need to log in before you can comment on or make changes to this bug.