Bug 17998 - Upgrade from 4.70 fails to run triggerpostun script
Summary: Upgrade from 4.70 fails to run triggerpostun script
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-01 06:17 UTC by kenneth_porter
Modified: 2015-12-01 13:23 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 00:21:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kenneth_porter 2000-10-01 06:17:38 UTC
Upgraded initscripts from 4.70. It appears that the spec file is assuming that both triggerpostun scripts will run, one for upgrade from pre-5.04 
and one for upgrade from pre-4.72. Only the first runs, so the code that migrates FORWARD_IPV4 in /etc/sysconfig/network to 
net.ipv4.ip_forward in /etc/sysctl.conf fails to run, and forwarding is then disabled even if it was previously enabled. This also affects 
net.ipv4.ip_always_defrag, kernel.sysrq, and kernel.stop-a. rpm-3.0.5-9.6x was used to upgrade.

Comment 1 Bill Nottingham 2001-01-30 00:21:22 UTC
This sounds like an rpm problem.


Comment 2 Jeff Johnson 2001-02-21 18:59:41 UTC
There was a problem with trigger handling in rp[m-4.0, fixed in rpm-4.0.1 and
later.
Please reopen if the problem persists.

Comment 3 openshift-github-bot 2015-12-01 13:23:35 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/0b25b36eed72e2f92fb7ca9b81067ce4702f2435
UPSTREAM: 18000: Fix test failure due to days-in-month check. Issue #17998.


Note You need to log in before you can comment on or make changes to this bug.