Bug 179982 - 2.6.15-1.1830_FC4 changes wlan0 to eth1? hostap broken?
2.6.15-1.1830_FC4 changes wlan0 to eth1? hostap broken?
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 02:44 EST by Jeff Gustafson
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 13:16:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Gustafson 2006-02-04 02:44:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5

Description of problem:
I noticed that wlan0 no longer works and it seems to be replaced with eth1.  The driver identifies the card as a Prism I card instead of a Prism 2.5 card.  It seems to be using the orinoco driver instead of the hostap one, even though they *both* load up.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1830_FC4

How reproducible:
Always

Steps to Reproduce:
1.  Just insert the card.
2.
3.
  

Additional info:
Comment 1 Lonni J Friedman 2006-02-04 15:19:38 EST
This bug is biting me too, but I think its a udev bug, not a kernel bug, because
even if I go back to booting the previous FC4 kernel, I continue to have the
same problem.

I've got a Linksys WPC11v3 PCMCIA wifi card that uses the orinoco driver.  Since
the udev update to 0.71 as soon as I try to bring up the interface for the wifi
card, I start getting an un-ending stream of errors like this:
cannot change name of wlan0 to devWXYZ: File exists

where WXYZ seems to be a random number that changes each time the error appears
(and it appears many times per second, but gradually slows down over time).

This is really really bad.

Please can the submittor of this bug change the 'component' to udev and the
priority/severity to high?
Comment 2 Jeff Gustafson 2006-02-14 14:19:47 EST
It appears the 1831 update fixed the problem (unless some other component was
also updated).  I have my wlan0 back!  Thanks!
Comment 3 Lonni J Friedman 2006-02-14 14:25:03 EST
Its not fixed for me.  Only downgrading udev avoids this.
Comment 4 Jeff Gustafson 2006-02-14 15:57:57 EST
'rpm -q udev' shows me running 'udev-071-0.FC4.2'

I wonder what else has changed.  Under 1830 I tried installing hostap-drivers
and it didn't fix the problem, leading me to belive that it wasn't some sort of
kernel issue.  I didn't know udev could assign the interface names.
Comment 5 Pekka Savola 2006-02-23 07:04:16 EST
FWIW -- I had a converse problem.  Orinoco_cs which was eth1 got renamed to
wifi0/wlan0, and ifcfg-eth1 ceased to work as is.

I had to:
 1) change the interface names eth1 -> wlan0
 2) add "MODE=Managed", because otherwise the driver (hostap?) defaulted to
"Master" (running in AP mode)

So, the fix 1) is easy but should be automatic; 2) is a high-priority problem.

Or maybe the problem is misasscociating orinoco_cs cards to use hostap?
Comment 6 Dave Jones 2006-02-27 00:10:42 EST
The problem is the hostap and orinoco drivers both claim support for the same
hardware.  I'm not sure what the best way forward is here.  John, any ideas?
Comment 7 John W. Linville 2006-02-27 13:52:03 EST
I don't have a really good answer for this...do both drivers work equally  
well?  It looks like there may be hw covered by orinoco that isn't covered by  
hostap?  But, none of that is PCI...  
  
Maybe notting has suggestions?  I suppose we could remove configuration for 
one of the drivers...hmmm... 
Comment 8 Bill Nottingham 2006-02-27 14:13:45 EST
The problem is that given a particular modalias, udev will load both drivers, so
it's "whichever matches first wins". We could selectively blacklist one of the
drivers, but I don't know enough to say which we should.
Comment 9 John W. Linville 2006-03-03 17:08:29 EST
There was a recent patch upstream which touches close to this issue.  Test 
kernels w/ that patch available here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Please give those kernels a try and post the results here...thanks! 
Comment 10 Pekka Savola 2006-03-07 03:11:06 EST
I'm not sure who was the target of comment #9..

I didn't need to test the Linville kernel, because the recent 2.6.15-1.1833_FC4
kernel seemed to fix my orinoco_cs -> hostap misassociation problem by default.
Comment 11 John W. Linville 2006-04-21 13:16:49 EDT
Closed due to lack of response.  Please reopen when the requested information 
becomes available...thanks! 
Comment 12 Lonni J Friedman 2006-04-21 13:20:31 EDT
Urmm, this is very badly broken in FC5 as well.  Can someone please reopen this?

Note You need to log in before you can comment on or make changes to this bug.