Bug 179991 - sound-juicer crashes with smp kernel (i686), works OK with non-smp kernel
sound-juicer crashes with smp kernel (i686), works OK with non-smp kernel
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 05:50 EST by Michael Cornelison
Modified: 2013-03-13 00:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 10:44:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cornelison 2006-02-04 05:50:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
CD content is displayed normally. 
When extract button is pressed, sound-juicer window vanishes.

Note that this happens only with smp version of kernel.
If I use non-smp kernel, juicer works normally.

I noticed this problem with earlier versions of smp kernel,
but this is the first time I reported the bug.



Version-Release number of selected component (if applicable):
sound-juicer.i386-2.10.1-1 + kernel-smp.i686-2.6.15-1.1830_FC4

How reproducible:
Always

Steps to Reproduce:
1.load CD
2.start sound-juicer
3.wait for track list to appear
4.press extract button
5.sound-juicer window disappears
  

Actual Results:  sound-juicer crashed or exited.
no messages found in /var/log/messages


Expected Results:  ripping of CD tracks should proceed normally
(and it does if I boot to non-smp version of kernel)

Additional info:

1. the chosen juicer file format was mp3.

2. PC: AMD64 X2 with nVidia nForce4 chipset
   (Shuttle SN25P)
Comment 1 John (J5) Palmieri 2006-02-06 10:08:10 EST
Can you try ripping to Flac or Ogg and see if it gives you a problem?
Comment 2 Michael Cornelison 2006-02-06 15:05:48 EST
Ogg works OK. mp3 continues to crash. 

I ran juicer from a terminal to capture the crash message:

Couldn't find matching gstreamer tag for track-count
Couldn't find matching gstreamer tag for encoder
Couldn't find matching gstreamer tag for encoder-version
Segmentation fault

Note that this happens only in smp kernel. Uniprocessor kernel works OK.
Comment 3 John (J5) Palmieri 2006-02-06 15:36:18 EST
Most likely the mp3 codec crashing.  Can you install the debuginfo package for
gstreamer, gstreamer-plugins and totem and then run it in gdb and attach a
backtrace to this bug.
Comment 4 John (J5) Palmieri 2006-02-06 15:36:59 EST
I ment sound-juicer not totem :-)
Comment 5 Michael Cornelison 2006-02-08 13:33:33 EST
"run it in gdb" is greek to me. give me an hint and I will try.
Comment 6 John (J5) Palmieri 2006-02-08 13:44:01 EST
yum install gdb
yum install gstreamer-debuginfo
yum install gstreamer-plugins-dbuginfo
yum install sound-juicer-debuginfo

gdb sound-juice

(gdb) set logging on [FILENAME]
(gdb) run

after it crashes:

(gdb) bt
(gdb) quit

Attach the file you logged to to this bug report.  Thanks.
Comment 7 Michael Cornelison 2006-02-11 02:36:43 EST
gdb: OK
gstreamer-debuginfo: not found (yum list gstreamer*)
gstreamer-plugins-debuginfo: OK
sound-juicer-debuginfo: not found (yum list sound-juicer*)

Note: now using smp kernel build 1831 which was released Feb. 9.

$ gdb sound-juicer:
 - CD content was listed OK
 - click on "extract" button: nothing happens
 - log file shows segmentation fault
 
gdb logfile follows:

Starting program: /usr/bin/sound-juicer 
Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x454000
(no debugging symbols found)
 ... many repititions
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208441152 (LWP 3890)]
(no debugging symbols found)
 ... many repititions
(no debugging symbols found)
[New Thread -1210541136 (LWP 3893)]
[New Thread -1210979408 (LWP 3894)]
[New Thread 49839024 (LWP 3896)]
[Thread 49839024 (LWP 3896) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208441152 (LWP 3890)]
0x058be100 in fht_3DN () from /usr/lib/libmp3lame.so.0
#0  0x058be100 in fht_3DN () from /usr/lib/libmp3lame.so.0
#1  0x05887de8 in fft_long () from /usr/lib/libmp3lame.so.0
#2  0x05891e4e in apply_preset () from /usr/lib/libmp3lame.so.0
#3  0x0589517c in L3psycho_anal_ns () from /usr/lib/libmp3lame.so.0
#4  0x05887519 in lame_encode_mp3_frame () from /usr/lib/libmp3lame.so.0
#5  0x0588a205 in lame_encode_frame () from /usr/lib/libmp3lame.so.0
#6  0x0588a472 in lame_encode_buffer_sample_t () from /usr/lib/libmp3lame.so.0
#7  0x0588ac3d in lame_encode_buffer_interleaved ()
   from /usr/lib/libmp3lame.so.0
#8  0x00a4a390 in gst_lame_get_type ()
   from /usr/lib/gstreamer-0.8/libgstlame.so
#9  0x07b3f986 in gst_pad_call_chain_function ()
   from /usr/lib/libgstreamer-0.8.so.1
#10 0x07b3cf74 in gst_pad_push () from /usr/lib/libgstreamer-0.8.so.1
#11 0x00a38ebd in gst_audio_convert_chain (pad=0x87e4700, data=0x85d1ea4)
    at gstaudioconvert.c:274
#12 0x07b3f986 in gst_pad_call_chain_function ()
   from /usr/lib/libgstreamer-0.8.so.1
#13 0x07b3cf74 in gst_pad_push () from /usr/lib/libgstreamer-0.8.so.1
#14 0x00a69abc in ?? () from /usr/lib/gstreamer-0.8/libgstoptscheduler.so
#15 0x00a69277 in ?? () from /usr/lib/gstreamer-0.8/libgstoptscheduler.so
#16 0x00a6e00d in ?? () from /usr/lib/gstreamer-0.8/libgstoptscheduler.so
#17 0x07b4bead in gst_scheduler_iterate () from /usr/lib/libgstreamer-0.8.so.1
#18 0x07b1dd27 in gst_bin_sync_children_state ()
   from /usr/lib/libgstreamer-0.8.so.1
#19 0x07b60c02 in gst_marshal_BOOLEAN__VOID ()
   from /usr/lib/libgstreamer-0.8.so.1
#20 0x00fbdd9b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#21 0x00fbe285 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0x00fcc8e7 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#23 0x00fcdc23 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0x00fce223 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#25 0x07b1df26 in gst_bin_iterate () from /usr/lib/libgstreamer-0.8.so.1
#26 0x0083b730 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#27 0x008394ce in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x0083c4d6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#29 0x0083c7c3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#30 0x00c74a46 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x08050c06 in main ()
The program is running.  Exit anyway? (y or n) 
Comment 8 John (J5) Palmieri 2006-02-13 10:44:48 EST
Closing CANTFIX.  The problem is in the lame encoder which we do not support or
even ship (#0  0x058be100 in fht_3DN () from /usr/lib/libmp3lame.so.0 is where
the crash happens).  Solution is to talk to the packager where you get the lame
mp3 encoder from and point them to this bug report.  Sorry I can't be of more
assistance. 

Note You need to log in before you can comment on or make changes to this bug.