Bug 180001 - Radeon 9000 Pro card detected as vesa driver
Radeon 9000 Pro card detected as vesa driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-02-04 09:10 EST by Mike Chambers
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 06:25:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Config file with ATI driver and correct monitor (2.60 KB, application/octet-stream)
2006-02-04 09:14 EST, Mike Chambers
no flags Details
Detected Config file (2.57 KB, application/octet-stream)
2006-02-04 09:15 EST, Mike Chambers
no flags Details
Server log (45.54 KB, text/x-log)
2006-02-04 09:18 EST, Mike Chambers
no flags Details
autodetected xorg.conf file (vesa found) (2.55 KB, text/plain)
2006-02-04 10:14 EST, Clyde E. Kunkel
no flags Details
log file of ati driver for radeon 9200 AGP (49.77 KB, text/plain)
2006-02-04 10:15 EST, Clyde E. Kunkel
no flags Details
radeon 9200 AGP log file (50.96 KB, text/plain)
2006-02-06 10:00 EST, Clyde E. Kunkel
no flags Details

  None (edit)
Description Mike Chambers 2006-02-04 09:10:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
When running system-config-display --reconfig (after xorg.conf file was renamed), Radeon 9000 Pro video card is found as vesa driver instead of the ati driver.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7.3-2

How reproducible:
Always

Steps to Reproduce:
1.update xorg-x11-drv-ati to latest version in rawhide
2.rename /etc/X11/xorg.conf file
3.run system-config-display --reconfig
  

Actual Results:  Card was detected as vesa driver instead of ati driver.

Expected Results:  Should had detected the ati driver.

Additional info:
Comment 1 Mike Chambers 2006-02-04 09:14:43 EST
Created attachment 124163 [details]
Config file with ATI driver and correct monitor

This is after I changed the driver to ati and updated the monitor to the
correct one.
Comment 2 Mike Chambers 2006-02-04 09:15:32 EST
Created attachment 124164 [details]
Detected Config file

This is the config file that was created when first running
system-config-display --reconfig.
Comment 3 Mike Chambers 2006-02-04 09:18:28 EST
Created attachment 124165 [details]
Server log
Comment 4 Clyde E. Kunkel 2006-02-04 10:14:36 EST
Created attachment 124166 [details]
autodetected xorg.conf file (vesa found)

Same problem with Radeon 9200 AGP card.  Attached is xorg.conf with vesa. 
Changing to ati works fine.

Pertinent lspci:

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200]
(rev  01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200]
(Secondary)  (rev 01)
0

During the gui autodetection I noticed that the card was identified as the
(Secondary) one.  No monitor is attached to this output.
Comment 5 Clyde E. Kunkel 2006-02-04 10:15:49 EST
Created attachment 124167 [details]
log file of ati driver for radeon 9200 AGP
Comment 6 Mike A. Harris 2006-02-05 12:02:11 EST
It appears that kudzu might be broken as most of the cards people have
reported so far, are already listed in the radeon.xinf file.  ;o/

I'm waiting for feedback from Bill/Jeremy about the parsing.

Will update after I hear back.
Comment 7 Clyde E. Kunkel 2006-02-06 09:59:06 EST
New ati driver responded the same as the previous version of the driver with AGP
radeon 9200:

[root@P4C800ED ~]# rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.5.7.3-3
[root@P4C800ED ~]# sysem-config-display --reconfig
[root@P4C800ED ~]# cat /etc/X11/xorg.conf | grep Driver
        Driver      "kbd"
        Driver      "mouse"
        Driver      "vesa"
[root@P4C800ED ~]# 

(restarted x server here via reboot of computer to confirm...yes, vesa loaded)

[root@P4C800ED ~]# sed -i -e 's|"vesa"|"ati"|' /etc/X11/xorg.conf
[root@P4C800ED ~]# cat /etc/X11/xorg.conf | grep Driver
        Driver      "kbd"
        Driver      "mouse"
        Driver      "ati"
[root@P4C800ED ~]#

(restarted x server here  (ctrl-alt-bs) to confirm .... yes, ati now working)

Comment 8 Clyde E. Kunkel 2006-02-06 10:00:48 EST
Created attachment 124260 [details]
radeon 9200 AGP log file
Comment 9 Clyde E. Kunkel 2006-02-06 13:33:00 EST
I don't know if this means anything or not, but, kudzu -p lists the secondary
port (not being used in my system) of the radeon card first and the primary port
next.  If the driver probs the first kudzu port it finds for a monitor and finds
none, then maybe it decides to configure the vesa driver even tho it does find a
monitor on the primary port.
Comment 10 Cord Kielhorn 2006-02-06 16:02:37 EST
Same here: (xorg-x11-drv-ati-6.5.7.3-3, system-config-display-1.0.36-1)

The graphics card has two devices (1002:5961 and 1002:5941 (secondary)).
s-c-d chooses "vesa", but "ati" works perfectly. Only 1002:5961 is listed in
radeon.xinf. "kudzu -p -c video" lists 1002:5941 (secondary) first. BTW,
1002:5941 is listed in /usr/share/hwdata/pci.ids, which is at least open()ed by
s-c-d.
Comment 11 Clyde E. Kunkel 2006-02-20 19:53:11 EST
FC5T3 clean install properly detected radeon 9200 (not even secondary!), allowed
me to set correct resolution and, voila!, booted up beautifully.  First time for
the FC5 series.  Nice work.  

I do wonder tho that it didn't configure dual head.  I am going to play with
dual head now with system-config-display since I have both AGP and PCI radeon
9200s with tube on one and flat panel on the other.
Comment 12 Mike A. Harris 2006-02-21 06:25:41 EST
(II) PCI: 01:00:0: chip 1002,5961 card 1002,2002 rev 01 class 03,00,00 hdr 80
(II) PCI: 01:00:1: chip 1002,5941 card 1002,2003 rev 01 class 03,80,00 hdr 00


This is quite odd.  They are reversed from the normal order they're seen in.
Nonetheless, only the class 0300 device is relevent to X.  The class 0380
device is not used by X hardware detection, and is only used by Windows.


(In reply to comment #11)
> FC5T3 clean install properly detected radeon 9200 (not even secondary!), allowed
> me to set correct resolution and, voila!, booted up beautifully.  First time for
> the FC5 series.  Nice work.  

Thanks for the update.

Setting status to "RAWHIDE"
Comment 13 Cord Kielhorn 2006-02-22 16:31:21 EST
Works as expected now: (xorg-x11-drv-ati-6.5.7.3-4, system-config-display-1.0.36-1)

s-c-d chooses "radeon".

Thank you Mike

Note You need to log in before you can comment on or make changes to this bug.