Bug 180005 - kernel unable to re-read partition table on install
Summary: kernel unable to re-read partition table on install
Status: CLOSED DUPLICATE of bug 180004
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-04 14:56 UTC by sjm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 03:44:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sjm 2006-02-04 14:56:43 UTC
Description of problem:
The full message:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
  diskset.savePartitions ()
 File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
  disk.commit()
error: Warning: The kernel was unable to re-read the partition table 
on /dev/hda (Device or resource busy).  This means Linux won't know anything 
nothing about the modifications you made until you reboot.  You should reboot 
your computer before doing anything with /dev/hda.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FC4 on Toshiba Satellite P20
2. Choose auto partition
3. choose any packages
  
Actual results:
Bails out after selecting packages

Expected results:
Install FC4


Additional info:
manually partitioning seems to have done the job

Comment 1 sjm 2006-02-05 01:30:14 UTC
Sorry about the duplicate bug.  I filed a bug against Bugzilla because it asked
me to resubmit (bug #180044).

Comment 2 Chris Lumens 2006-02-05 03:44:55 UTC

*** This bug has been marked as a duplicate of 180004 ***


Note You need to log in before you can comment on or make changes to this bug.