Bug 180016 - PCIID not recognised
PCIID not recognised
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 13:28 EST by Andy Burns
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 11:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My everyday working Xorg config with manual driver/chipid (2.60 KB, text/plain)
2006-02-04 13:28 EST, Andy Burns
no flags Details
auto generated config file (2.44 KB, text/plain)
2006-02-04 13:37 EST, Andy Burns
no flags Details
Log file from starting x with auto generated config (59.08 KB, text/plain)
2006-02-04 13:39 EST, Andy Burns
no flags Details
xorg startup with radeon driver forced (21.46 KB, text/plain)
2006-02-09 05:13 EST, Andy Burns
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 4284 None None None Never

  None (edit)
Description Andy Burns 2006-02-04 13:28:22 EST
Description of problem:

Radeon X550 PCIe card not recognised by "system-config-display --reconfig"
but works with manual ChipId/Driver settings

Version-Release number of selected component (if applicable):

Name   : xorg-x11-drv-ati
Arch   : x86_64
Version: 6.5.7.3
Release: 2

Actual results:

various log and conf files attached ...
Comment 1 Andy Burns 2006-02-04 13:28:22 EST
Created attachment 124176 [details]
My everyday working Xorg config with manual driver/chipid
Comment 2 Andy Burns 2006-02-04 13:37:31 EST
Created attachment 124177 [details]
auto generated config file

Produced a new config file 

# system-config-display --reconfig --verbose --noui

Trying with card: ATI Technologies Inc RV370 secondary [ATI Sapphire X550
Silent]
Backing up /etc/X11/xorg.conf as /etc/X11/xorg.conf.backup
Writing configuration to /etc/X11/xorg.conf
Removing old /etc/X11/X
Creating /etc/X11/X symlink
Comment 3 Andy Burns 2006-02-04 13:39:06 EST
Created attachment 124178 [details]
Log file from starting x with auto generated config
Comment 4 Mike A. Harris 2006-02-05 11:20:19 EST
Thanks for testing.

I've reviewed your attachments, and your config file is configured to use
the "vesa" driver, and the log file is a log from using the vesa driver.

What is needed, is for you to run system-config-display --reconfig and then
examine the xorg.conf.  If it has the "vesa" driver present, you need to
manually change it to "radeon" and do not add or remove or modify anything
else in the config.  Then start the X server and see if the card works with
the "radeon" driver.  If it does, without adding any other options, then
your card is supported by the radeon driver, and I need you to attach the
X server log file and config file from the new working session.  That
shows the PCI ID, and confirms that the driver supports the hardware
natively.

Once I have that info, I can update the radeon.xinf to map your card to the
Radeon driver, and it should autodetect it properly then.

Thanks in advance.
Comment 5 Andy Burns 2006-02-08 04:09:54 EST
OK, I've been a away a day or two and still got to dash now, so no time to
perform the test on latest driver until later today or tomorrow, but if you
didn't change the PCIIDs in the driver since the X11R7RC4 then I can confirm
that simply changing the driver isn't enough, I had to also add the ChipId to
force it to believe it would handle it ...
Comment 6 Mike A. Harris 2006-02-08 04:56:43 EST
[radeon.xinf]
alias pcivideo:v00001002d00005B63sv*sd*bc*sc*i* radeon


This chip is already listed.  If it doesn't autodetect properly, file a bug
against kudzu.
Comment 7 Andy Burns 2006-02-09 05:13:23 EST
Created attachment 124426 [details]
xorg startup with radeon driver forced

just tried again before I saw comment #5 so will post those results anyway

I upgraded packages to latest rawhide 
   xorg-x11-server-Xorg 1.0.1-5 
   xorg-x11-drv-ati 6.5.7.3-3

did the system-config-display --reconfig which detected vesa, changed only the
vesa to radeon, restarted X which failed with no screens, log file attached.
Comment 8 Andy Burns 2006-02-09 05:35:51 EST
Mid-Air collision avoided and freedesktop.org bugzilla id# corrected!

yes the "v00001002d00005B63sv*sd*" looks correct to match the card

# lspci -vn

01:00.0 0300: 1002:5b63
        Subsystem: 174b:1490

01:00.1 0380: 1002:5b73
        Subsystem: 174b:1491

# lspci -v

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 [ATI Sapphire X550
 Silent] (prog-if 00 [VGA])
        Subsystem: PC Partner Limited Unknown device 1490

01:00.1 Display controller: ATI Technologies Inc RV370 secondary [ATI Sapphire X
550 Silent]
        Subsystem: PC Partner Limited Unknown device 1491

Perhaps that is where system-config-display gets the message 
"Trying with card: ATI Technologies Inc RV370 secondary [ATI Sapphire X550
Silent]" from. 

Given that when I force the radeon driver it fails, but it works when I also add
the chipid doesn't that still indicate a driver issue? (just to be clear the
actual card is 0x5B63 but I have to force it to 0x5B62) if there is *also* a
kudzu issue I'm happy to file a bug for it too ...
Comment 9 Bill Nottingham 2006-02-10 11:34:36 EST

*** This bug has been marked as a duplicate of 176978 ***
Comment 10 Andy Burns 2006-02-13 17:35:45 EST
OK, over on BZ#176978, notting has fixed kudzu and/or s-c-display so that

# system-config-display --reconfig --verbose --noui

now *does* decide to use the radeon driver for this card, instead of the vesa
one, however X still refuse to start until I add "ChipId 0x5B62"

Comment 11 Andy Burns 2006-04-07 06:42:40 EDT
Revisiting my old bugs ...

Up to yesterday my system was still running rawhide from just pre-FC5 with post
FC5-updates, so I flattened it and installed FC5.

Booted from DVD, when anaconda tried to start X it saw the X550 card, but failed
to start X using radeon driver, it then also failed to start using the VESA
driver (don't know why that should fail), so I had to do my installation using
vnc, which went OK.

http://adslpipe.co.uk/pics/fc5x550.jpg

After installation X still failed to start until I added my old faithful "ChipId
0x5b62" to xorg.conf which was necessary all through the FC5 test series.

I know this bug was bounced between X and kudzu, but somewhere along the way it
still doesn't work in FC5, it's not a big problem for me as I know how to work
around it, but perhaps it could get some attention for FC6?

Comment 12 Bill Nottingham 2006-04-07 09:37:08 EDT
OK, if we're picking radeon by default, but it's not working, that's a driver
issue. Assigning there.
Comment 13 Mike A. Harris 2006-06-14 11:15:41 EDT
Hmm, from the last few comments it would sound as if the PCI ID list inside
the driver may have a typo or missing entry in one location.

Investigating ...



------- Additional Comments From mharris@redhat.com  2006-06-10 05:56 EST -------
Ok...  it turns out that the driver does not actually support this chip
at all currently, which is why it is not working for you until you force
the chip ID.

Forcing the ChipID tells the driver to ignore what your hardware really
is, and pretend to be another chip, so the driver then gladly pretends
you have a 1002:5B62 which /is/ supported.  If the 5B63 chip works close
enough to the 5B62, then the result is working video, however this is not
always the case.

It appears that it works ok for you, so we can update the radeon driver's
internal PCI ID lists to detect this chip automatically now, and treat
it like the 5B62 internally.  If there are any differences in the
chips however, you may experience problems.  If that happens, you'll need
to file a bug report to X.Org at http://bugs.freedesktop.org for
investigation.

In the mean time though, I think it is safe to update the driver to
handle this chip so long as you seem to be having no problems with it
as things stand currently.


------- Additional Comments From mharris@redhat.com  2006-06-10 06:10 EST -------
* Sat Jun 10 2006 Mike A. Harris <mharris@redhat.com> 6.5.7.3-4.FC5.0
- Added ati-radeon-pci-id-update.patch, which adds support for Sapphire X550,
  1002:5B63 for bug (#180016)

When we do an ati driver update for FC5, this fix will be included.

------- Additional Comments From mharris@redhat.com  2006-06-10 06:11 EST -------
The chip is already supported in rawhide, so closing as "RAWHIDE", however
as indicated above, it'll also be released in a future FC5 update as well.


------- Additional Comments From fedora@adslpipe.co.uk  2006-06-10 14:13 EST -------
(In reply to comment #14)

> > In the mean time though, I think it is safe to update the driver to
> > handle this chip so long as you seem to be having no problems with it
> > as things stand currently.

After forcing the ChipID the only issue I have had was when under a xen kernel,
where some slight garbling happened, this was "usually" repeatable for me and
confirmed as also affecting Daniel Veillard 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183341






Note You need to log in before you can comment on or make changes to this bug.