Bug 1800335 - iwlwifi: Can't parse phy_sku in B0, empty sections (missing firmware?)
Summary: iwlwifi: Can't parse phy_sku in B0, empty sections (missing firmware?)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-06 21:35 UTC by rvcsaba
Modified: 2020-02-29 03:21 UTC (History)
19 users (show)

Fixed In Version: kernel-5.5.6-201.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-29 03:21:07 UTC
Type: Bug


Attachments (Terms of Use)
dmesg (76.34 KB, text/plain)
2020-02-06 21:35 UTC, rvcsaba
no flags Details
dmesg 5.5.5 (83.36 KB, text/plain)
2020-02-20 09:41 UTC, rvcsaba
no flags Details
dmesg 5.5.6 kernel and lspci -v (18.56 KB, application/x-xz)
2020-02-24 20:47 UTC, rvcsaba
no flags Details


Links
System ID Priority Status Summary Last Updated
Linux Kernel 206329 None None None 2020-02-24 12:39:41 UTC

Description rvcsaba 2020-02-06 21:35:02 UTC
Created attachment 1661561 [details]
dmesg

1. Please describe the problem:

[    9.721729] iwlwifi 0000:03:00.0: Can't parse phy_sku in B0, empty sections
[    9.721734] iwlwifi 0000:03:00.0: Failed to read NVM: -61
[    9.721738] iwlwifi 0000:03:00.0: Collecting data: trigger 16 fired.
[    9.722153] iwlwifi 0000:03:00.0: Start IWL Error Log Dump:
[    9.722156] iwlwifi 0000:03:00.0: Status: 0x00000040, count: 6
[    9.722157] iwlwifi 0000:03:00.0: Loaded firmware version: 29.1654887522.0
[    9.722159] iwlwifi 0000:03:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN       
[    9.722161] iwlwifi 0000:03:00.0: 0x000002F0 | trm_hw_status0
[    9.722162] iwlwifi 0000:03:00.0: 0x00000000 | trm_hw_status1
[    9.722163] iwlwifi 0000:03:00.0: 0x0004171E | branchlink2
[    9.722165] iwlwifi 0000:03:00.0: 0x000446B2 | interruptlink1
[    9.722166] iwlwifi 0000:03:00.0: 0x000446B2 | interruptlink2
[    9.722167] iwlwifi 0000:03:00.0: 0x00000000 | data1
[    9.722168] iwlwifi 0000:03:00.0: 0x00000080 | data2
[    9.722170] iwlwifi 0000:03:00.0: 0x07030000 | data3
[    9.722171] iwlwifi 0000:03:00.0: 0x00000000 | beacon time
[    9.722172] iwlwifi 0000:03:00.0: 0x00002502 | tsf low
[    9.722174] iwlwifi 0000:03:00.0: 0x00000000 | tsf hi
[    9.722175] iwlwifi 0000:03:00.0: 0x00000000 | time gp1
[    9.722176] iwlwifi 0000:03:00.0: 0x00002503 | time gp2
[    9.722178] iwlwifi 0000:03:00.0: 0x00000009 | uCode revision type
[    9.722179] iwlwifi 0000:03:00.0: 0x0000001D | uCode version major
[    9.722180] iwlwifi 0000:03:00.0: 0x62A39462 | uCode version minor
[    9.722182] iwlwifi 0000:03:00.0: 0x00000220 | hw version
[    9.722183] iwlwifi 0000:03:00.0: 0x00C89200 | board version
[    9.722184] iwlwifi 0000:03:00.0: 0x00110188 | hcmd
[    9.722186] iwlwifi 0000:03:00.0: 0x00022000 | isr0
[    9.722187] iwlwifi 0000:03:00.0: 0x00000000 | isr1
[    9.722188] iwlwifi 0000:03:00.0: 0x00000002 | isr2
[    9.722189] iwlwifi 0000:03:00.0: 0x004000C0 | isr3
[    9.722191] iwlwifi 0000:03:00.0: 0x00000000 | isr4
[    9.722192] iwlwifi 0000:03:00.0: 0x00110188 | last cmd Id
[    9.722193] iwlwifi 0000:03:00.0: 0x00000000 | wait_event
[    9.722195] iwlwifi 0000:03:00.0: 0x000000D4 | l2p_control
[    9.722196] iwlwifi 0000:03:00.0: 0x00000000 | l2p_duration
[    9.722197] iwlwifi 0000:03:00.0: 0x00000000 | l2p_mhvalid
[    9.722198] iwlwifi 0000:03:00.0: 0x00000000 | l2p_addr_match
[    9.722200] iwlwifi 0000:03:00.0: 0x00000007 | lmpm_pmg_sel
[    9.722201] iwlwifi 0000:03:00.0: 0x16070617 | timestamp
[    9.722202] iwlwifi 0000:03:00.0: 0x00341018 | flow_handler
[    9.722341] iwlwifi 0000:03:00.0: Fseq Registers:
[    9.722390] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_ERROR_CODE
[    9.722440] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_TOP_INIT_VERSION
[    9.722495] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_CNVIO_INIT_VERSION
[    9.722544] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_OTP_VERSION
[    9.722593] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_TOP_CONTENT_VERSION
[    9.722648] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_ALIVE_TOKEN
[    9.722703] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_CNVI_ID
[    9.722708] iwlwifi 0000:03:00.0: 0x00000000 | FSEQ_CNVR_ID
[    9.722757] iwlwifi 0000:03:00.0: 0x00000000 | CNVI_AUX_MISC_CHIP
[    9.722811] iwlwifi 0000:03:00.0: 0x00000000 | CNVR_AUX_MISC_CHIP
[    9.722816] iwlwifi 0000:03:00.0: 0x00000000 | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[    9.722865] iwlwifi 0000:03:00.0: 0x00000000 | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[    9.722924] iwlwifi 0000:03:00.0: Firmware not running - cannot dump error
[    9.735098] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -61


2. What is the Version-Release number of the kernel:

5.5.2-200.fc31.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

5.3.18 work. I don't tested 5.4 series, because Bug 1783667 - i915 GPU hang.


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Yes. I boot my computer.


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:


6. Are you running any modules that not shipped with directly Fedora's kernel?:

No.


7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Comment 1 rvcsaba 2020-02-12 08:49:04 UTC
I tested it with 5.5.3-200.fc31.x86_64. Same problem, iwlwifi not work. :(

Comment 2 rvcsaba 2020-02-14 10:18:36 UTC
Related?

https://bugzilla.kernel.org/show_bug.cgi?id=206329

Comment 3 rvcsaba 2020-02-20 09:41:27 UTC
Created attachment 1664303 [details]
dmesg 5.5.5

Same problem with 5.5.5 kernel.

Comment 4 rvcsaba 2020-02-24 20:47:04 UTC
Created attachment 1665499 [details]
dmesg 5.5.6 kernel and lspci -v

Same problem with 5.5.6 kernel. :(

Comment 5 Julian Sikorski 2020-02-24 20:59:51 UTC
This is the patch supposed to fix the problem:
https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers.git/commit/?id=a9149d243f259ad8f02b1e23dfe8ba06128f15e1
I have not tested it myself yet.

Comment 6 rvcsaba 2020-02-25 08:37:11 UTC
5.5.6-201.fc31.x86_64 work, thank you very much! :)

Comment 7 Fedora Update System 2020-02-25 12:29:16 UTC
FEDORA-2020-3cd64d683c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cd64d683c

Comment 8 Fedora Update System 2020-02-27 18:34:49 UTC
kernel-5.5.6-201.fc31, kernel-headers-5.5.6-200.fc31, kernel-tools-5.5.6-200.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3cd64d683c

Comment 9 Fedora Update System 2020-02-29 03:21:07 UTC
kernel-5.5.6-201.fc31, kernel-headers-5.5.6-200.fc31, kernel-tools-5.5.6-200.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.