Bug 180035 - /usr/bin/ld: cannot find -lltdl
/usr/bin/ld: cannot find -lltdl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libtool-libs13 (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Alexandre Oliva
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 17:26 EST by Marcel Nijenhof
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 10:38:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Nijenhof 2006-02-04 17:26:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I can't link against -lltdl because the link to "libltdl.so" doesn't exists.

Version-Release number of selected component (if applicable):
libtool-ltdl-1.5.16.multilib2-3

How reproducible:
Always

Steps to Reproduce:
1 Create "hello.c" with a small c programm
2. gcc -O2 -o hello hello.c -lltdl  

Actual Results:  $ gcc -O2 -o hello hello.c -lltdl
/usr/bin/ld: cannot find -lltdl
collect2: ld returned 1 exit status


Expected Results:  It should link. I have the libries installed

Additional info:

After creating the symlink it works:

1) cd /usr/lib
2) ln -s libltdl.so.3 libltdl.so
Comment 1 Alexandre Oliva 2006-02-05 10:38:13 EST
You need to install libtool-ltdl-devel

Note You need to log in before you can comment on or make changes to this bug.