Bug 180037 - kernel-smp-2.6.15-1.1830_FC4 breaks alsa
kernel-smp-2.6.15-1.1830_FC4 breaks alsa
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2006-02-04 17:49 EST by Phil Anderson
Modified: 2015-01-04 17:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 15:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Anderson 2006-02-04 17:49:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
After upgrading to 2.6.15-1.1830, amixer, alsamixer or any other mixer program fails to start or work, printing the following to the conosle:

ALSA lib simple_none.c:1216:(simple_add1) helem (MIXER,'Front Playback Volume',0,0,0) appears twice or more

Downgrading to any older kernel release fixes the problem.

A quick look on google shows many others who are having the same problem with 2.6.15.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 2.6.15-1.1830 on a computer with a Sound Blaster Live (snd_emu10k1)
2. System boots up with all chanels muted
3. amixer, alsamixer, etc are all unable to unmute the mixer
  

Additional info:
Comment 1 stef 2006-02-04 17:59:01 EST
I saw this problem too, the channels were mutted the first time I started with
the 2.6.15-1.1830 kernel, however I was able to unmute with the gnome volume
controler.

System is x86_64 (Opteron), my sound card is SoundBlaster Live! + Live! Drive panel.
Comment 2 Thomas Canniot 2006-02-06 02:24:51 EST
The Gnome volume controller says that no volume control devices are present.
However I am able to unmute the volume with the volume control applet in gome
panel, but no sound can be heard. My sound card is a Creative Labs SB Live!
EMU10k1 (rev 0a).
I am running a non-smp kernel : kernel-2.6.15-1.1830_FC4
Comment 3 Phil Anderson 2006-02-06 03:58:11 EST
I can confirm that my gnome volume control also says that no volume control
devices are present.  Reverting back to the last 2.6.14 kernel fixes the problem.
Comment 4 Phil Anderson 2006-02-10 06:36:39 EST
See alsa bug for a fix & more details
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=1799
Comment 5 Dave Jones 2006-02-19 00:04:30 EST
Can you try the 1832 kernel at http://people.redhat.com/davej/kernels/Fedora/FC4
Comment 6 Phil Anderson 2006-02-19 06:29:41 EST
1832 fixed the problem for me.  The channels were all muted when I first booted
this kernel, but this time I was able to unmute them.
Comment 7 Anders Truelsen 2006-02-23 08:14:57 EST
I've installed 1832, no channels seems to be muted but I still get no sound :-(
Any suggestions?
Comment 8 FX 2006-02-28 18:12:05 EST
I had the exact same problem and installing the 1832 kernel at
http://people.redhat.com/davej/kernels/Fedora/FC4 and running the soundcard
detection once again after that did the trick!

Note You need to log in before you can comment on or make changes to this bug.