Bug 1800426 - [sriov] the SR-IOV device and CNI plugin pods are stuck in 'Terminating' state for a long time.
Summary: [sriov] the SR-IOV device and CNI plugin pods are stuck in 'Terminating' stat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 03:05 UTC by Peng Liu
Modified: 2020-05-13 21:57 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:57:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 148 0 None closed BUG 1800426: Not delete the daemonset of device and cni plugins, delete the pods instead 2020-02-24 02:06:32 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:57:11 UTC

Description Peng Liu 2020-02-07 03:05:33 UTC
Description of problem:
The SR-IOV device and CNI plugin pods are stuck in 'Terminating' state after the last user-defined SriovNetworkNodePolicy CR is deleted. It doesn't always happen.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy the operator
2. Apply a SriovNetworkNodePolicy CR and wait until the node sync state becomes 'Succeeded'
3. Delete the SriovNetworkNodePolicy CR

Actual results:
The SR-IOV device and CNI plugin pods are stuck in 'Terminating' state for more than 5 mins.

Expected results:
The SR-IOV device and CNI plugin pods can be removed in 1 min.

Additional info:

Comment 2 zhaozhanqi 2020-02-11 06:49:45 UTC
Verified this bug with image
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.4.0-202002101346-ose-sriov-network-webhook
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.4.0-202002101346-ose-sriov-network-operator
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.4.0-202002101346-ose-sriov-network-config-daemon

this issue did not be reproduced.

Comment 4 errata-xmlrpc 2020-05-13 21:57:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.