Bug 180043 - gedit text pane scrolls to top when cursor placed in pane for the first time
gedit text pane scrolls to top when cursor placed in pane for the first time
Status: CLOSED DUPLICATE of bug 169123
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
4
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-04 19:23 EST by Ben Caradoc-Davies
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 03:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Caradoc-Davies 2006-02-04 19:23:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.7.12) Gecko/20060202 Fedora/1.0.7-1.2.fc4 Firefox/1.0.7

Description of problem:
The first time clicking on body text, the cursor is placed correctly but the text widget scrolls to the top of the document, typically moving the cursor out of view. Subsequent clicks do not cause this behaviour.

Version-Release number of selected component (if applicable):
gedit-2.10.2-4

How reproducible:
Always

Steps to Reproduce:
1. Open a text file with gedit. The file should be at least two windows long.
2. Use the scrollbar to scroll to the bottom of the text.
3. Click on the body text.
  

Actual Results:  The cursor was be placed correctly, but the text pane scrolled to the top of the document, obscuring the cursor.

Expected Results:  The text pane should not have scrolled in response to the mouse-driven cursor placement. The cursor should be visible to the user.

Additional info:

This behaviour only happens the first time the cursor is paced in the text pane. The workaround is to click on the pane before using the scroll bar. Or to scroll, click, curse, and scroll again.
Comment 1 Frank Arnold 2006-02-05 02:58:54 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

See bug 169123
Comment 2 Ignacio Vazquez-Abrams 2006-02-05 03:04:05 EST

*** This bug has been marked as a duplicate of 169123 ***

Note You need to log in before you can comment on or make changes to this bug.