Bug 1800437 - "oc get volumesnapshot" should show volumesnapshot status
Summary: "oc get volumesnapshot" should show volumesnapshot status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Christian Huffman
QA Contact: Wei Duan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 04:24 UTC by Wei Duan
Modified: 2020-07-13 17:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Included additional details when querying VolumeSnapshot resources. Reason: The `oc get` information only displayed the name and creation time of the resource. Result: Now the `oc get` information includes additional details, such as the associated VolumeSnapshotContent, VolumeSnapshot source, and other relevant information.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:32 UTC

Description Wei Duan 2020-02-07 04:24:02 UTC
Description of problem:
volumesnapshot have status/bond info like PVC, but in current OCP version, only name and age displayed.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-06-230833

How reproducible:
Steps to Reproduce:
1.create volumesnapshot
2.oc get volumesnapshot

Actual results:
$ oc get volumesnapshot
NAME    AGE
vs-01   2m4s

Expected results:
more useful info need display

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
Jan report on upstream
https://github.com/kubernetes-csi/external-snapshotter/issues/247

Comment 2 Christian Huffman 2020-02-17 21:56:13 UTC
Upstream PR has been submitted at [1].

[1] https://github.com/kubernetes-csi/external-snapshotter/pull/256

Comment 3 Christian Huffman 2020-02-27 19:20:04 UTC
Upstream PR has been merged. I've submitted [1] to include this in the operator we ship.

[1] https://github.com/openshift/cluster-csi-snapshot-controller-operator/pull/30

Comment 12 Chao Yang 2020-03-24 03:16:30 UTC
oc get volumesnapshot
NAME                READYTOUSE   SOURCEPVC   SOURCESNAPSHOTCONTENT   RESTORESIZE   SNAPSHOTCLASS   SNAPSHOTCONTENT                                    CREATIONTIME   AGE
new-snapshot-test   true         pvc1                                2Gi           ebs-snap        snapcontent-7cd4d9f6-d289-4cb2-837a-5b8edfcf25cf   16m            16m

Comment 14 errata-xmlrpc 2020-07-13 17:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.