Bug 1800448 - Chart links in project Utilization card all return 404
Summary: Chart links in project Utilization card all return 404
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Rastislav Wagner
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 06:24 UTC by Yadan Pei
Modified: 2020-05-04 11:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:34:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4291 0 None closed Bug 1800448: Do not specify perspective for dev monitoring so we can acces the rou… 2020-05-04 06:50:28 UTC
Github openshift console pull 4333 0 None closed Bug 1800448: Fix incorrect link in view more for dev perspective metrics 2020-05-04 06:50:29 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:35:11 UTC

Description Yadan Pei 2020-02-07 06:24:47 UTC
Description of problem:
Click on chart link in project Utilization card results in 404 Page Not Found

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-06-230833

How reproducible:
Always

Steps to Reproduce:
1. normal user create a project, add some workloads
2. click on chart links in project Utilization card

Actual results:
2. All links returns 404 Page Not Found

Expected results:
2. Click on these charts should take user to Developer -> Monitoring -> Metrics with query string applied

Take CPU usage as an example, the correct links to Developer -> Monitoring -> Metrics is 
https://console-openshift-console.apps.juzhao-ops.qe.rhcloud.com/dev-monitoring/ns/testuser2-1/metrics?query0=topk%2825%2C+sort_desc%28sum%28avg_over_time%28pod%3Acontainer_cpu_usage%3Asum%7Bcontainer%3D%22%22%2Cpod%21%3D%22%22%2Cnamespace%3D%27testuser2-1%27%7D%5B5m%5D%29%29+BY+%28pod%2C+namespace%29%29%29

Now in Utilization card it's 
https://console-openshift-console.apps.juzhao-ops.qe.rhcloud.com/dev-monitoring/ns/testuser2-1/metrics?query0=namespace%3Acontainer_cpu_usage%3Asum%7Bnamespace%3D%27testuser2-1%27%7D

Additional info:

Comment 1 Rastislav Wagner 2020-02-12 09:48:09 UTC
Not specify to dashboard, the issue occurs for any chart (ie in pod details page).

Comment 3 Yadan Pei 2020-02-14 03:10:14 UTC
normal user view metrics on project Utilization card, the chart links to correct page, but when clicking on 'View more' in metrics breakdown, it reports 404 


This is checked against 4.4.0-0.nightly-2020-02-13-192852

Comment 5 Yadan Pei 2020-02-18 09:29:22 UTC
Click 'View more' in breakdown window goes to right page now, verified on 4.4.0-0.nightly-2020-02-17-211020

Comment 7 errata-xmlrpc 2020-05-04 11:34:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.