Bug 1800459 - [RFE] Add column Storage Class for PVCs
Summary: [RFE] Add column Storage Class for PVCs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1807195
TreeView+ depends on / blocked
 
Reported: 2020-02-07 07:07 UTC by Liang Xia
Modified: 2020-07-13 17:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add column Storage Class for PVCs Reason: Enhancement Result: Working as expected
Clone Of:
: 1807195 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:14:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
PVCs does not show storage class info (153.31 KB, image/png)
2020-02-07 07:07 UTC, Liang Xia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:14:32 UTC

Description Liang Xia 2020-02-07 07:07:02 UTC
Created attachment 1661613 [details]
PVCs does not show storage class info

Description of problem:
As admin, when checking all PVCs in management console, I can not tell which storage class does the PVC belong to.
I have to click into the PVC detail to know that info which is really unacceptable when there are many storage class/PVCs.

While in CLI, I can get that info easily for all PVCs.
$ oc get pvc -A
NAMESPACE           NAME                      STATUS   VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS                  AGE
openshift-storage   db-noobaa-core-0          Bound    pvc-d2907a7a-717c-4495-b606-66bd16120e1b   50Gi       RWO            ocs-storagecluster-ceph-rbd   18m
openshift-storage   ocs-deviceset-0-0-tk2km   Bound    pvc-1764a7ff-3964-4277-982a-6d2a97b3d3ad   2Ti        RWO            standard                      18m
openshift-storage   ocs-deviceset-1-0-vfclj   Bound    pvc-4ca2d0d7-1f8c-4c34-a4e9-ad1addc1cde3   2Ti        RWO            standard                      18m
openshift-storage   ocs-deviceset-2-0-vtwb8   Bound    pvc-1d0aacaa-9bf5-417d-a5a8-42d64c3cb52f   2Ti        RWO            standard                      18m
openshift-storage   rook-ceph-mon-a           Bound    pvc-4cae8da6-5fd9-48fe-8eea-4b059931cd6f   10Gi       RWO            standard                      21m
openshift-storage   rook-ceph-mon-b           Bound    pvc-99a6f6c4-9d97-4ce7-ba41-077b378a41d8   10Gi       RWO            standard                      21m
openshift-storage   rook-ceph-mon-c           Bound    pvc-5836e386-f5b6-47de-9814-e8f0a604b31d   10Gi       RWO            standard                      21m


Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-06-230833

How reproducible:
Always

Steps to Reproduce:
1. Create severa PVCs which belongs to different storage classes.
2. Check those PVCs in management console.
3.

Actual results:
It is hard to get storage class info for all the PVCs in management console.

Expected results:
Get storage class info for all the PVCs should be as easy as the CLI does.

Additional info:
Refer to "pvc-does-not-show-storage-class-info.png"

Comment 3 Yanping Zhang 2020-05-11 09:02:40 UTC
Checked on ocp 4.5 cluster with payload 4.5.0-0.nightly-2020-05-10-231314.
Create pvc in project from console, then check on pvcs list page, there is "Storage Class" column, and it showes the sc for the pvc.
The bug is fixed, so move it to Verified.

Comment 5 errata-xmlrpc 2020-07-13 17:14:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.