Bug 1800488 - Windows guest tool container image added with VM Detail page Modal is incorrect in d/s
Summary: Windows guest tool container image added with VM Detail page Modal is incorre...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Radim Hrazdil
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 09:09 UTC by Radim Hrazdil
Modified: 2020-04-20 11:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-20 11:16:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4242 0 None closed Bug 1800488: Fix d/s windows guest tools container image 2020-04-20 09:05:52 UTC

Description Radim Hrazdil 2020-02-07 09:09:35 UTC
Description of problem:
According to a CNV documentation, the windows gest tools containerdisk should look like the following:
- containerDisk:
    image: cnv-tech-preview/virtio-win
  name: windows-guest-tools

However, the UI Modal window adds the following:
- containerDisk:
    image: virtio-win-container
  name: windows-guest-tools

Which leads to Failed to pull image "virtio-win-container": rpc error: code = Unknown desc = Error reading manifest latest in docker.io/library/virtio-win-container: errors: denied: requested access to the resource is denied unauthorized: authentication required


Version-Release number of selected component (if applicable):
OCP 4.3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dan Kenigsberg 2020-02-07 10:22:26 UTC
I believe that both docs and code should point to https://access.redhat.com/containers/#/registry.access.redhat.com/container-native-virtualization/virtio-win

Comment 2 Petr Kotas 2020-02-07 14:14:27 UTC
With the help of Radim, we figured the issue.

Red Hat Enterprise Linux CoreOS release 4.3 is based on RHEL 7, therefore it has the registries configured as:

```
# This is a system-wide configuration file used to
# keep track of registries for various container backends.
# It adheres to TOML format and does not support recursive
# lists of registries.

# The default location for this configuration file is /etc/containers/registries.conf.

# The only valid categories are: 'registries.search', 'registries.insecure', 
# and 'registries.block'.

[registries.search]
registries = ['registry.access.redhat.com', 'docker.io']
```

The image is stored at registry.redhat.io which is present by default on RHEL 8 based hosts.

The simplest solution is to provide full path to the image as generated in the UI.
Another possible solution is to add the registry to the host, which is an unnecessary complication that can cause possible issues.

Comment 3 Andrew Burden 2020-02-11 12:10:20 UTC
Docs PR posted in related bug: BZ#1800979

Petr, the prerequisite for both procedures says:
"Download the cnv-tech-preview/virtio-win container disk from the Red Hat Container Catalog. This is not mandatory, because the container disk will be downloaded from the Red Hat registry if it not already present in the cluster, but it can reduce installation time."

Does your previous comment mean the second sentence is incorrect, and that it won't be downloaded because the registry is not present on the host?

Comment 4 Petr Kotas 2020-02-12 11:55:53 UTC
As far as I understood the issue. The bug applies only on CoreOS host. For full RHEL it should be fine.
Although I need to check further what is the target registry.

Comment 6 Guohua Ouyang 2020-02-24 03:19:44 UTC
The image is "registry.redhat.io/container-native-virtualization/virtio-win" and it's can be pulled "Successfully pulled image "registry.redhat.io/container-native-virtualization/virtio-win"".
Verified on 4.4.0-0.nightly-2020-02-22-102956


Note You need to log in before you can comment on or make changes to this bug.