Bug 1800492 - [RFE] Storage: Missing VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapshot info for storage in management console.
Summary: [RFE] Storage: Missing VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapsh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Jilju Joy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 09:21 UTC by Liang Xia
Modified: 2020-10-27 15:55 UTC (History)
9 users (show)

Fixed In Version: 4.6.0-0.nightly-2020-08-03-025909
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:55:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Volume Snapshots page screenshot (117.71 KB, image/png)
2020-09-22 06:46 UTC, Jilju Joy
no flags Details
Volume Snapshot Classes page screenshot (91.96 KB, image/png)
2020-09-22 06:48 UTC, Jilju Joy
no flags Details
Volume Snapshot Contents page screenshot (112.17 KB, image/png)
2020-09-22 06:49 UTC, Jilju Joy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:55:31 UTC

Description Liang Xia 2020-02-07 09:21:18 UTC
Description of problem:
Check storage part in management console, there are no info about VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapshot, thus admin can not manage those resource via management console.

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-06-230833

How reproducible:
Always

Steps to Reproduce:
1. Create VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapshot (one of them is also OK).
2. Go to management console and check storage part.


Actual results:
No info about VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapshot.



Expected results:
Show info for VolumeSnapshotClass/VolumeSnapshotContent/VolumeSnapshot


Additional info:
The relationship between VolumeSnapshot, VolumeSnapshotContent and VolumeSnapshotClass is quite similiar to
PersistentVolumeClaim/PersistentVolume/StorageClass.

Comment 2 Nishanth Thomas 2020-03-18 07:07:26 UTC
@kmurarka@redhat.com, please prioritize this with PM for 4.5

Comment 3 Kanika Murarka 2020-04-02 10:49:49 UTC
Moving this out of 4.5 because snapshot feature is moved to 4.6.

Comment 4 Kanika Murarka 2020-08-03 06:21:04 UTC
The list for the objects are added:
Volumesnapshot: https://github.com/openshift/console/pull/5902
VolumeSnapshotContent: https://github.com/openshift/console/pull/5980
VolumesnapshotClass: https://github.com/openshift/console/pull/5931

Comment 7 Jilju Joy 2020-09-22 06:45:48 UTC
Verified in version:

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-22-000541   True        False         97m     Cluster version is 4.6.0-0.nightly-2020-09-22-000541

ocs-operator.v4.6.0-90.ci

Volume Snapshots, Volume Snapshot Classes and Volume Snapshot Contents details are available as separate pages.

Screenshots are attached.

Comment 8 Jilju Joy 2020-09-22 06:46:50 UTC
Created attachment 1715634 [details]
Volume Snapshots page screenshot

Comment 9 Jilju Joy 2020-09-22 06:48:33 UTC
Created attachment 1715636 [details]
Volume Snapshot Classes page screenshot

Comment 10 Jilju Joy 2020-09-22 06:49:20 UTC
Created attachment 1715637 [details]
Volume Snapshot Contents page screenshot

Comment 12 errata-xmlrpc 2020-10-27 15:55:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.